Skip to Content

Unable to deploy application through NWDS 7.3

Hi Experts,

I am facing a problem which is as follows:

1. I am unable to add a particular server under SAP AS Java in NWDS

[Checks already done]:

a. Tried adding other servers - This is working fine.

b. Checked logs - No errors for the activity.

c. Pinged the server and the telneted the port - No issues.

d. Checked the default.pfl file - entry set to default.

e. Checked that the server was up and running.

2. I then went into Management Console view

[Checks done]:

a. Tried adding other servers - They were getting added without any issues.

b. Tried adding the server which was not getting added in Preferences.

- I was prompted to enter J2EE administrator password. On adding the password, the server was visible in Management Console, and also on SAP AS Java (yay... 🤣).

My Problem is that now when I make the thusly added server as my default server and try to deploy my application, I get the following message in Deploy View Console:

No default SAP system found in the configuration. Goto Window > Preferences > SAP AS Java to set or register one. [WARNING: Jul 18, 2016 4:57:26 PM /userOut/daView_category (eclipse.UserOutLocation) [Thread[Worker-118,5,main]] ]

Can you please let me know if there is any config/activity that I am missing.

Looking forward to your inputs.

Best Regards,

Rohit Singhal

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Jul 18, 2016 at 12:30 PM

    Hello Rohit,

    Firstly, please restart the sapstartsrv service.

    Please open SAP MMC and check the AccessLists.

    If your OS is more sophisticated one (like LINUX, HP-UX & etc.) you might use this command:

    sapcontrol -nr <xx> -function GetAccessPointList ,

    where <xx> is the number of the instance where the P4 port is open and active

    Please refer to this SAP note:

    2134934 - How to properly test the P4 port of an AS Java

    and execute this test for the P4 port.

    Provided the P4 port is visible / open / active, then please make sure you have not changed the standard ICM ports in the instance profile

    icm/server_port_<xx>

    https://help.sap.com/saphelp_nwpi711/helpdata/en/48/3ae05299c172d0e10000000a42189c/content.htm

    You might make a backup and delete the "Standard" ICM ports that are mentioned in this guide. The Standard icm/server_port_<xx> do exist anyway.

    The main reason of all these actions is to confirm that the P4 port is open & active. (because if this is not the case no deployment might take place)

    Also please make sure you have opened the particular P4 port in the firewall. I do hope you do not try to deploy through P4SSL because this requires additional configuration settings.

    Regards

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.