Skip to Content

Hybrid App Build using Web IDE

Dear All,

I'm trying to build hybrid app using web ide HAT kit on my laptop. The console log says below.

9:34:40 PM (project type) project_type_project_configured_multiple_definition

9:35:05 PM (hybrid-toolkit)

9:35:05 PM (hybrid-toolkit) =================================================

9:35:05 PM (hybrid-toolkit) Exporting the hybridapp project from Orion...

9:35:05 PM (hybrid-toolkit)

9:35:06 PM (hybrid-toolkit) Check if there is any referenced user library

9:35:06 PM (hybrid-toolkit) This project does not reference any user project.

9:35:06 PM (hybrid-toolkit)

9:35:06 PM (hybrid-toolkit) Sending the zipped project to Hybrid App Toolkit...

9:35:10 PM (hybrid-toolkit)

9:35:10 PM (hybrid-toolkit)

9:35:10 PM (hybrid-toolkit) ----------------------------------------------

9:35:10 PM (hybrid-toolkit) Preparing project: Name - "hybridapp"

9:35:10 PM (hybrid-toolkit) Try killing residual adb process, if any...

9:35:10 PM (hybrid-toolkit) SUCCESS: The process "adb.exe" with PID 11624 has been terminated.

9:35:10 PM (hybrid-toolkit) Try killing residual xde process, if any...

9:35:10 PM (hybrid-toolkit) ERROR: The process "xde.exe" not found.

9:35:10 PM (hybrid-toolkit)

9:35:10 PM (hybrid-toolkit) - The project already exists. Clean its webapp folder first...

9:35:40 PM (hybrid-toolkit)

9:35:40 PM (hybrid-toolkit) - Removing unused data from project.json...

9:35:40 PM (hybrid-toolkit)

9:35:40 PM (hybrid-toolkit) - Checking SAPUI5 library for app packaging...

9:35:40 PM (hybrid-toolkit) Use the default SAPUI5 library sapui5-mobile.zip.

9:35:40 PM (hybrid-toolkit)

9:35:40 PM (hybrid-toolkit) - Checking SAPUI5 library version...

9:35:41 PM (hybrid-toolkit)

9:35:41 PM (hybrid-toolkit) - Applying device configuration and web asset...

9:42:23 PM (hybrid-toolkit)

9:42:23 PM (hybrid-toolkit) Running app on device...

9:42:44 PM (hybrid-toolkit) Error: Current working directory is not a Cordova-based project.

9:42:44 PM (hybrid-toolkit) run android exited with error code 1

9:42:44 PM (hybrid-toolkit) The node process of the "run" script exited with code 1.

9:42:44 PM (hybrid-toolkit) The run command execute failure reason: Hybrid Toolkit utility exited with error

It never proceeds after the step Runnin app on device . Any idea what is missing?

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Jul 18, 2016 at 05:40 AM

    Hi @Thomas Zang - can you please assist?

    Thanks,
    Michal.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.