Skip to Content
avatar image
Former Member

Problem accessing load balance url via soap sender.

Hi everyone!!!

We have configured load balance in our PI enviroment.

The wsdl url was changed to the new load balance url but we have problems when we try to send a message via soap ui or another system using SOAP protocol.

We have PI 7.31 java-only.

*Notice, only syncronous SOAP messages throw this error.

Regards,

Roger.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Jul 13, 2016 at 08:24 PM

    Hi Rogerio,

    From the error it seems like the load balancer is not routing the data to the adapter engine. please get in touch with basis/infrastructure team to enable this.

    Hope it helps!

    Ambrish

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 13, 2016 at 06:38 PM

    What is the error thrown?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Sritharan,

      Returns this message at soap ui:

      <html>

      <head>

      <title>MessageServlet</title>

      </head>

      <body>

      <h3>Message Servlet is in Status OK</h3>

      <h3>Status information:</h3>

      Servlet com.sap.aii.adapter.soap.web.MessageServlet (Version $Id: //tc/xpi.adapters/NW731EXT_07_REL/src/_soap_application_web_module/webm/api/com/sap/aii/adapter/soap/web/MessageServlet.java#3 $) bound to /MessageServlet

      <br/>

      Classname ModuleProcessor: null

      <br/>

      Lookupname for localModuleProcessorLookupName: localejbs/ModuleProcessorBean

      <br/>

      Lookupname for remoteModuleProcessorLookupName: null

      <br/>

      ModuleProcessorClass not instantiated

      <br/>

      ModuleProcessorLocal is Instance of com.sun.proxy.$Proxy540

      <br/>

      ModuleProcessorRemote not instantiated

      </body>

      </html>

      When I use the server url instead the load balance url it works properly.