Skip to Content
author's profile photo Former Member
Former Member

Input-ready query with a comment not working for Integrated Business Planning

Dear All,

I would like to create an input-ready query with a comment column.

I have a real-time Infocube with the ZCHAR characteristic, a 0CURRENCY and a ZKFIG key figure.

Moreover, I have a DSO created by flagging the Direct Upload and Planning Mode checkboxes, with the same ZCHAR, 0CURRENCY characteristics and a characteristic set up as key figure, ZCOMM.

The, I have included these DSO and Infocube into a MultiProvider and this one has been linked to an Aggregation Level.

I have identified all the characteristics as belonging to both providers, while the ZKFIG has been assigned only to the Infocube and the ZCOMM only to the DSO.

I have created a BeX query, starting from the Aggregation Level, with ZCHAR and 0CURRENCY in rows, ZKFIG and ZCOMM in column (input-ready).

Then, I have specified in the query designer, for the two key figures, the related infoprovider from which KFs belong.

I have connected this query into an Analysis for Office report but I am able to input data only into the ZKFIG, i.e. the infocube's key figure.

Please find below the errors I am getting when I try to input comments into the ZCOMM KF.

'Not all key fields of <DSO> can be filled (RSPLS_CR-080, <system>)'

'Multiprovider <MULTIPROVIDER>: cannot change the Key Figure <ZCOMM KF>'

Furthermore, after performing the check of aggregation level, there is the below green message:

'Keyfield <0CURRENCY> of the DSO <DSO> must be contained in aggregation level <AGGREGATION LEVEL>


In some other posts or documents there is the suggestion to set up the characteristic relations and/or data slices. I have tried to follow these advices but with no positive results.

I have also tried to let in the multiprovider/aggregation level only the DSO with characteristics as keyfigure and it works correctly. The same happens letting only the infocube with its characteristics/key figures in the multiprovider/aggregation level.

Could you please advice on the above matter? Please find attached the errors faced.

Thank you very much for your support.

Kind Regards,

Daniele

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Jul 11, 2016 at 08:20 AM

    Hi Former Member

    First try to remodel the DSO to contain 0Currency or any other unit or currency field in the Keys section. Then activate the DSO.

    Later, For this message 'Keyfield <0CURRENCY> of the DSO <DSO> must be contained in aggregation level <AGGREGATION LEVEL> , It seems that you might have missed adding the Characteristic unit 0CURRENCY from the dso into the ALVL . Please try adding it and check the ALVL.

    Then coming to Char as KF. There is a similar question to yours , try going through this conversation.

    Also for future questions related to Business planning , please post your queries in this community page .

    Business Planning

    Hope this helps.

    Regards

    Tharun

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.