Skip to Content
author's profile photo Former Member
Former Member

Job running in foreground displays data but no data in background

Hi ABAP Experts,

I wonder if you could give me some hints about this situation. When I run the program in foreground, I retrieve data. But I scheduled it in background and I checked the spool, there is no data !!!

Running in foreground

Running in background

Thanks and regards,

Danny

Capture1.PNG (18.9 kB)
Capture2.PNG (3.9 kB)
Capture3.PNG (11.5 kB)
Capture4.PNG (10.2 kB)
Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

2 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jul 08, 2016 at 04:54 AM

    Hi Danny,

    Check if any condition written in program for sy-batch.

    Also open the completed background job in SM37 tcode and select it by selecting checkbox and give JDBG code in command prompt. It will start debugging background job.By debug you will able to find root cause of the issue..

    Regards,

    Pravin

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 08, 2016 at 01:05 AM

    best solution is to debug the job background/foreground.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.