Skip to Content
avatar image
Former Member

Problems using ESRI On Premise in Lumira 1.31.0?

Hello,

As of Lumira's latest update, version 1.31.0, we have been wanting to use the added "ESRI On Premise" feature to make use of geographical data hosted on our own servers.

However, having tried to connect to our ESRI-enabled development server (ArcGIS Online), and attempting to use the Geo Map visualization under the "Visualize" tab, we continue to see the same default error message in Lumira:

Unable to connect to the Esri map service. Please check network and proxy settings.


Looking at the screenshot, you can see that this feature requires a valid username, password, and portal URL.

  • We are also of the understanding from SAP release notes that a valid certificate is needed for our IIS server. Is this certificate quintessential for achieving a connection to our server?
  • Also, what is the typical format of a portal URL? Are there any port numbers involved?

Any additional resources would be very helpful for reference purposes.

Thank you.

Capture.PNG (16.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    Jul 21, 2016 at 02:58 AM

    Hi,

    portal URL to be configured in Preference is

    Example : Portal URL  = https://<server>/arcgisportal/sharing/rest/

    Lumira adds the below to the portal URL for connection to ESRI

    ESRI Login URl =  Portal URL  + /generatetoken

    ESRI  Portal Self URL = Portal URL  + /portals/self

    ESRI  Custom URL = Portal URL  + /content/users/

    ESRI  Service URL =  Portal URL  + /content/items/

    Regarding Certificate: Yes, we need a valid certificate for the Server. This is because we use token based authentication to connect to ESRI Map. In token based authentication , first we generate a token by firing an AJAX post call with login credentials to https://<server>/arcgisportal/sharing/rest/generatetoken

    Thanks,

    Ashok

    Add comment
    10|10000 characters needed characters exceeded

    • What's considered a valid certificate?

      I still can't get our layers to show in lumira and i'm wondering if it's because our certificate is to weak/not valid?

      Seems like we have a valid certificate but Chrome thinks that it's too weak (SHA-1). Could that be the problem for us? Feels like i'm grasping at straws here but worth we really want to get it working.

      I have published several different FeatureServices containing Polygon-shapes but lumira just says "No feature service was found for your account."

      I have tried all kinds of proxy settings with no luck.

      Thanks

      Jonathan

  • Jul 04, 2016 at 06:54 AM

    We have the same problem when trying to get Esri on premise working in Lumira.

    When I look at the data traffic through Fiddler I can see that lumira is trying to reach http://OurArcGisServer/portal/portals/home

    Even though our ArcGIS server is located at OurArcGisServer/portal (which i've entered in preferences in lumira) it seems like lumira adds /portals/home at the end of the URL.

    When I enter http://OurArcGisServer/portal/home in preferences for the geo map I can see that lumira tries to reach http://OurArcGisServer/portal/home/portals/self (????)

    The problem for us definetly seems to be that our arcgis on premise server isn't located at /portals but simply at /portal.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 22, 2016 at 12:31 PM

    I would also like to clarify that the version of the ArcGIS portal is 10.4.1. Does anyone have any success stories of connecting using the 'Esri on Premise' feature?

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 26, 2016 at 06:41 PM

    Added a suggestion into SAP IDEA PLACE to improve the way the ESRI Connections are Managed and Consumed in the CMC and SAP Lumira Desktop.

    Take a look and VOTE for it if you would find it helpful. Ideas need at least 15 votes to get attention by the Product Team....

    Support 'Managed' ESRI Connections in LUMIRA desktop and LS4BIP

    https://ideas.sap.com/D35289

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Aug 08, 2016 at 12:42 PM

    UPDATE:

    We were able to establish an Esri On Premise connection using the following URL:

    https://<server>/arcgis/sharing/rest

    However, now when navigating to the 'Visualize' tab, and selecting the "Geo Map" visualization to use the Esri services, Lumira simply hangs with the "Loading Esri Map" message and the map never actually renders.

    Has anyone experienced this issue while establishing Esri connectivity? Thanks.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Mark Richardson

      1. The Lumira application is being run on Windows 7 Entreprise.

      2. The default Esri connectivity is unknown due to our corporate proxy.

      3. The restrictions of the domain on which the application is run may be centrally-managed.

      I suppose it really could be any one of those things, we are planning to use packet-sniffing software as an aid as well.

  • Sep 08, 2016 at 06:13 PM

    Can somebody confirm is there no longer an out-of-the-box ESRI option as there was in Lumira 1.30? What are a customer's options if they have neither an ESRI online or on-premise license?

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      If Default Account option is chosen, SAP Lumira uses default connectivity for connecting to ESRI and render base map.

      If users enter credentials, SAP Lumira uses customer entered credentials to connect to ESRI.

      Thanks,

      Ashok