Skip to Content
0
Jun 29, 2016 at 11:01 AM

Issue with AS2 Service - PO

98 Views

Dear Experts,

We are trying to develop a scenario for AS2 to File for which, we are referring to the following blog.

http://scn.sap.com/docs/DOC-31349

To send message to PO's AS2 adapter, we are providing the following URI pattern to our partner.

http://<host>:<j2eeport>/AS2HttpAdapter/AS2AdapterFacade?FS=<from_service>&TS=<to_service>&IF=<outbound_interface> &NS=interface_namespace>

But, in the AS2 side, they are getting HTTP 404 - Requested resource doesn't exist.

We are getting same error, while trying to access the same URL on the browser.

We also tried the trimmed URL 'http://<host>:<j2eeport>/AS2HttpAdapter/AS2AdapterFacade' and 'http://<host>:<j2eeport>/AS2HttpAdapter' with the same error.

But the access point for SOAP Adapter 'http://<host>:<j2eeport>/XISOAPAdapter/MessageServlet' is working fine. That makes to believe that the Service for AS2 adapter has some issue, but we are struggling for a clue. We think, If there was any issue with the Integrated Configuration, it should have been a different error.

Could you please help?

Thanks,

Ashwin