Skip to Content
0

How to set a timeout for Analysis for MS Office Sessions

Feb 08, 2017 at 03:15 PM

814

avatar image

Hello,

Is there a way to define a timout for BIP sessions created via Analysis for MS Office?

Many thanks in advance!

Best Regards,

Alex

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Stephen Hobbs Jun 13, 2017 at 03:57 PM
1

I've been working with SAP and they have said that from Analysis version 2.3.1 there is now a config line in the Ao_app.config file

"After Analysis for Office 2.3 SP1, there is a setting in "'BOESessionRefreshTime" in Analysis for Office setting file %PROGRAMDATA%\Sap\Cof\Ao_app.config: First in the configSections and a second time right after the configSections. This second occurrence is the place where you can change the value. This allows you to choose the time interval for the BOESession refreshes. The time is in seconds. The default value of this setting is "-1". If you enter a negative value (or do not set the setting at all) the old behavior is used (AO takes the session timeout from the BOE). If you enter 0 no BOE session refreshes are done. Please backup this file before making changes."

You also need to add a session.timeout=3600 (or however may seconds) in the Program Files (x86)\SAP BusinessObjects\tomcat\webapps\dswsbobje\WEB-INF\classes\dsws.properties file

I have tested this on a pre-2.3.1 version (2.3.0) and if you put the <BOESessionRefreshTime value="0" /> into the C:\Users\<user>\AppData\Roaming\SAP\Cof\Ao_user_roaming.config file it also works.

Hope the above makes sense?

Regards,

Stephen

Share
10 |10000 characters needed characters left characters exceeded
Stephen Hobbs Feb 08, 2017 at 03:56 PM
0

This might help. SAP Note 1837122

Symptom:
How to increase the session timeout value in BI Launchpad and Central Management Console (CMC)

Resolution:
The default session timeout value for BI Launchpad and CMC is 20 minutes. Follow the below steps to increase the session timeout value as needed.
1. Stop Tomcat.
2. Navigate to the folder <BI 4.0 Install folder>\SAP BusinessObjects\Tomcat6\webapps\BOE\WEB-INF.
3. Open web.xml in Notepad and search for the following tag. <session-config> <session-timeout>20</session-timeout> </session-config>
4. Increase the session-timeout value longer than 20 minutes. For example, this sets the session timeout to 60 minutes. <session-config> <session-timeout>60</session-timeout> </session-config>
5. Start Tomcat.

Regards,

Stephen

Share
10 |10000 characters needed characters left characters exceeded
Alexander Stettler Feb 09, 2017 at 10:28 AM
0

Hi Stephen,

For BI Launchpad the settings you've described are working, but the settings does not have any effects to Analysis for MS Office. I've tried also the timeout settings behind the MDAS and DSWS but it seems that all this settings have also no effect to Analysis.

<INSTALLDIR>SAP BusinessObjects Enterprise XI 4.0\java\pjs\services\MDAS\resources\com\businessobjects\multidimensional\services
multidimensional.services.server.session.monitor.idle.timeout=1800000

<INSTALLDIR>\tomcat\webapps\dswsbobje\WEB-INF\classes\dsws.properties
qaaws.session.timeout=600 or rather session.timeout=600

Best Regards,
Alex

Share
10 |10000 characters needed characters left characters exceeded
Stephen Hobbs Mar 24, 2017 at 03:11 PM
0

Having just started using SSO with Analysis for Office in anger, I too am now finding that I can't see a way to control the timeout for Analysis connections via the BIP! My own answer doesn't work for Analysis but does for CMC and Launchpad.

Any ideas?

Thanks,

Stephen

Share
10 |10000 characters needed characters left characters exceeded