Skip to Content
author's profile photo Former Member
Former Member

Select alphanumeric values in Interval in Partitions SPO

Hi experts,

i have some values that I want to use them in partitions of SPOs as criteria which are alphanumeric(ex. "21-Cars"). So I created a partitions selecting the interval between 0* and 9* and I assume that all the values between 0-9 and starting with 0-9 will be falling in this interval. But actually this doesn't work. It works for characters like A* - B* or for numbers 0* - 9* but not for alphanumerical values. Could you please suggest how can I capture the alphanumeric values in the selection internval.

Thank you,
Regys

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Jun 26, 2016 at 06:40 PM

    Hi Regys

    Is it possible for you to create a field which will have 2 values 1 and 2 based on whether the original field is Alphanumeric or not ?

    Original Field new Field

    21-Cars 1

    21-21-21 0

    33-Bus 1

    Now, you can use new field for partitioning .

    Regards

    Anindya

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Anindya Bose

      Hi Anindya,

      If you use 0* - 9* or 0* both '021-CARS' and '021123* would fall in the same category logically.

      yes I was thinking the same but it wasn't working. No, I am not trying to keep alphanumeric in a separate partition, I wanted them to fall under this partition: 0*-9*.

      What is your Data Flow ? A) PSA---->SPO or B ) PSA---->DSO---->SPO ?

      My dataflow is PSA-DSO-SPO.

      Did you try *A* - *B* ? ---- here I am assuming either you have alphanumeric or full numeric material number ..

      I didn't try this, I tried only A*-B*. I wonder if I try *A* it would select all the materials that have A in it and this is not what I want.

      Perhaps maybe some other syntax would make the work but I am not finding it right.

      Regards,

      Regys

  • author's profile photo Former Member
    Former Member
    Posted on Jul 08, 2016 at 08:04 AM

    Also some of the characters are also not loaded to the target like entries starting with S, M, F. So I am wondering perhaps is the issue in the flat file loading but I tried different files and still it didn't work. Below is the partition I am working on.

    Any help on this issue please.

    Regards,

    Regys


    selection.PNG (21.3 kB)
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.