$(function () { pageContext.i18n.modTalk = 'moderation talk'; pageContext.i18n.replyToComment = 'Reply'; pageContext.i18n.modTalkEmpty = 'moderation talk is empty'; pageContext.url.getModTalk = "/comments/%25ID%25/listModTalk.json"; pageContext.url.possibleCommentRecipients = "/comments/%ID%/possibleRecipients.json"; pageContext.url.commentEdit = '/comments/%25ID%25/edit.html'; pageContext.url.commentView = '/comments/%ID%/view.html'; pageContext.i18n.commentVisibility = { 'full': 'Viewable by all users', 'op': 'Viewable by the original poster', 'mod': 'Viewable by moderators', 'opAndMod': 'Viewable by moderators and the original poster', 'other': 'Advanced visibility', 'dialogTitle': 'Comment visibility', 'selectGroups': 'Visible to groups', 'selectOther': 'Other recipients', 'selectOriginalPoster': 'Original poster', 'selectModerators': 'Moderators', 'selectAssignees': 'Asked to answer users' }; pageContext.i18n.commentMenuLabels = { 'comment-edit': 'comments.menu.edit', 'comment-delete': 'comments.menu.delete', 'comment-convert': 'comments.menu.convert' };pageContext.i18n.answer= { bestAnswer: 'Best Answer', controlBar : { accept: 'Accept', unaccept: 'Unaccept', acceptCommand: 'Accept this answer as correct', cancelAcceptedCommand: 'Remove this answers accepted status' } }; window.croles = { u: false, op: false, m: false, og: false, as: false, ag: false, dc: false, doc: false, eo: false, ea: false }; tools.init({ q: { e: false, ew: false, eo: false, r: false, ro: false, d: false, dow: false, fv: false, c: false, co: false, p: false, tm: false , ms: false, mos: false }, n: { f: false, vf: false, vfo: false, vr: false, vro: false, c: false, co: false, vu: false, vd: false, w: false, wo: false, l: false }, c: { e: false, eo: false, d: false, dow: false, ta: false, tao: false, l: false }, a: { e: false, ew: false, eo: false, d: false, dow: false, a: false, aoq: false, ao: false, tc: false, tco: false, p: false, tm: false }, pc: croles }, { tc: true, nsc: true }); commandUtils.initializeLabels(); }); Skip to Content
0

IT0015 wage type is not caluclated problaby in payroll

Feb 08, 2017 at 02:25 PM

103

avatar image
Former Member

Hi Experts,

I've a WT in IT0015 which takes input value as "Days"

when I enter 2 records for the same WT in the same month

in payroll simulation the first one has correct values. but the second record is missed up.

EXAMPLE:
---------------
in 01/2017 I've entered 2 WT of the same type

WT 9045 = 8 Days
WT 9045 = 2 Days

when I run the payroll the result is showing the first record has 8 days which is correct. but the second record is also set to 8 days... which should be 2.

here is the payroll result


and here is the pcr for WT 9045

when I remove the PCR from the schema. the result as days are correct.




what should I do in the PCR to fix this issue?

thanks

q1.png (12.6 kB)
q2.png (6.6 kB)
q3.png (4.9 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Rémi Corriveau Feb 08, 2017 at 05:30 PM
0

First thing to look at would be the log of the processing (Payroll Simulation with the "Display log" box checked) in Function P0015. It should read IT0015, process both entries through a pcr (is it the one your have shown?), and transfer the result into the Output Table (IT).

What are the values for the Number field of WT 9045 in the Output to Function P0045?

What are the values for the Number field of WT 9045 in the Input (IT) to the pcr you have shown?

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Thanks Remi,

Problem Solved,

I had to go again to processing class for WT9045 and I've disabled the Cumulation processing classes and it worked correctly.

0