Skip to Content

No receiver could be determined for ICO PI 7.3

Hi All,

I have created an ICO in PI 7.3. I have maintained necessary Integration engine configurations in ECC system SXMB_ADM to point to AAE .

This interface was working fine in Development but when we moved to QA, it is now throwing following error in PI abap stack.

I tried stopping the sender SOAP channel but still the message is coming in to the PI system and failing with following error:

<SAP:Code area="RCVR_DETERMINATION">NO_RECEIVER_CASE_ASYNC</SAP:Code>

<SAP:Stack>No receiver could be determined </SAP:Stack>


I'm not sure why this coming into ABAP stack . Could you please help me if I'm missing anything.


Thanks



Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • Jun 20, 2016 at 08:15 PM

    Hi Swetha,

    Please check if the destination is configured in PO QA env. Please check your configuration with the below document

    How to Set Up the Communication between ABAP Backend and SOAP Adapter using XI Protocol

    and blog - Integrate SAP PO and ECC Systems in three ways

    regards,

    Harish

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 20, 2016 at 10:18 PM

    Hi Swetha,

    Try a CPACache refresh.

    Thanks Faith

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jun 21, 2016 at 07:09 AM

    Hi Swetha,

    As per your inputs the message is sent to PI ABAP stack from there it is unable to find any further configuration so it is error out with No receiver found because it looking for Classical Scenario but in your case its ICO

    To avoid this by maintaining IS_URL configuration with respect to Namespace and service interface then the things will fall in Sync

    Hope this helps

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Venkat,

      I did maintain the SXMB_ADM config . This was working fine in Dev and only throwing error in QA. I tried switching to Classical scenario in QA and it did work . Issue is with only ICO.

  • Jun 21, 2016 at 07:59 AM

    Hello Swetha,

    Can you please check if there are any conditions set in receiver determination rules in the ICo, and if specified receiver communication component(s) is(are) correct / exist in QA environment?

    @Venkata: if the issue would have been in attempt of invocation of the configuration scenario / ICo that does not exist in a called Adapter Engine (for example, because it was deployed to a different Adapter Engine, etc.), then the error should have been related to CPA object not found exception.

    Regards,

    Vadim

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Swetha,

      You can find the trace like below.

      To be make sure 100% it is not typo error can you copy and paste from sxi_monitor of ECC system and paste it in sender ID after you save the sender ID, if you trigger from SPROXY or ABAP program you must reopen the transaction (by typing /nsproxy or /nse38) because if you are in the same screen then system will get the details from cache not from the table.

      Regards,

      Praveen.

      trace1.png (57.2 kB)
      sender1.png (8.2 kB)