Skip to Content
0
Jun 17, 2016 at 07:47 AM

ASSERTION_FAILED dump during EMMA case generation for implausible reads

88 Views

Hi All,

When I am trying to create the emma clarification case using EMMA Tcode. Its giving me dump with below message:

ASSERTION_FAILED

The ASSERT condition was violated.

what happened?

The current application program has detected a situation with the

ASSERT statement that should not occur.

The reason for this runtime error was one of the following:

- For the checkpoint group specified with the ASSERT statement, the

activation mode is "abort".

- A system variant has been used to set the activation mode to "abort"

globally for all checkpoint groups in this system.

- The activation mode is set to "abort" at program level.

- The ASSERT statement is not assigned to any checkpoint groups.

Program name where it is giving me dump is RSC1_ON_COMMIT_BUFFER: This program is being called when system try to create the delta.During debugging, I found that, When I remove following flags, KPI_REL flag from table EMMA_BPA and KPI_MSG flag and changed the value of field XBPAACT to 1 from EMMAC_BPA table for BPAREA "EMR" its not giving any dump.

Below is the piece of code:

* Threshold in number of lines to flush current buffer

READ TABLE it_data ASSIGNING <ls_data> INDEX 1.

ASSERT sy-subrc EQ 0 AND

<ls_data> IS ASSIGNED.

Here in internal table it_data in first iteration system creates two records but in second iteration it brings nothing and then dump comes. Not sure why it is coming here in second iteration when there was no data in table.

I don't want to change these config as it will result data not being updated in BI.

So please help how I can fix this error without changing the above config.

Thanks