Skip to Content

XML parse error

Hi Team,

Please provide your valuable suggestions for the error we are facing in the below scenario.

Scenario:

We are performing the Address Validation where,

input is Street and City,given to GAC transform(GB directory) which returns suggestions list related to it.

We are holding the Suggestion list in the XML structure, that's where we are facing the parsing issue.

Please find the below error for reference:

Note: For some inputs its working perfectly fine i.e. when input street and city the directory returns suggestion list and list is getting perfectly mapped to the XML structure prepared by us.

My current XML has UTF-8 encoding and I presume that some of the characters returned by the directory in suggestion list aren't supported by XML and as a result the XML is failing to parse if that is the case then How can I match the encoding of the directory and the XML?

Please provide your valuable suggestions.

Regards,

Santosh G.

1.png (5.7 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jun 17, 2016 at 01:24 PM

    I would start by looking at this kba: 1721845 - how to use suggestion lists.  it does link you to a wiki page which has detailed information on how to use them.  We have changed suggestions list some since the pages were written, but based on the error you're getting I think this should help get you started in the correct direction. 

    If you want to know what the suggestion list is going to return, you can set it up to run in Data Services Designer using an input xml file.  The standard debug processing would enable you to look at what Data Services is sending to your application. 

    Add comment
    10|10000 characters needed characters exceeded

    • House number and postcode in the UK data will typically give you an assignment in a lot of cases, which is usually more desirable than trying to wade through a suggestion list of more than 300 entries.  The way the UK addressing system work, those two fields should be included.