Skip to Content

SAP PI - SAP ECC Patch Upgraded

Hi All,

Recently we have upgraded our ECC system.

erp6 ehp7 support stack 4  to erp6 ehp 7 stack 9.

we didn't upgrade PI System.

our PI system details below:

SAP Release: 711

Support Package: 09.


I need some clarifications here.

we need to upgrade PI System also or not required?


The ECC system with details erp6 ehp 7 stack 9 can support SAP PI integration with

SAP Release: 711

Support Package: 09 or not?



Thanks In Advance,

Vishnu Pallamreddy.




Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Jun 16, 2016 at 06:44 AM

    Hi Vishnu,

    you do not need to upgrade your PI version for SAP ECC patch upgrade.

    regards,

    Harish

    Add comment
    10|10000 characters needed characters exceeded

    • Typically for such checks it is recommended to run the SAP Upgrade Dependency Analyzer at http://service.sap.com/uda

      • If you look at your current combination of ERP 6.0, EHP 7 with PI 7.11 in this tool, it will complain that this is not recommended and that PI needs to be upgraded.
      • You might wonder why this disclaimer from SAP - this is because, there could be cases where Standard Enterprise Services / Integration Content from SAP would not work, break.
      • In your case as you are already on this version and doing just a SP upgrade, ( while it is not a recommended version combination ) your flows should continue to work after SP Upgrade but do be aware that SAP Support might not support this for certain use - cases.
      • Finally check this link for supported combinations from SAP : Strategy beyond SAP Business Suite 7 Innovations 2011 - Landscape Governance - SCN Wiki

      72.png (43.1 kB)
  • Jun 16, 2016 at 09:04 AM

    Dear Vishnu,

    Please check SAP note 1388258 - Version Interoperability between SAP Business Suite and SAP Netweaver Systems, and refer to the PDF attachment on the bottom of the page.

    This PDF document clearly describes which backend systems can be compatible with which SAP Netweaver PI systems.

    According to the PDF document, for an ERP6 EHP7 system needs at least 7.30 Netweaver PI system in order to be compatible.

    Best regards,

    Bence

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Vishnu,

      If you want to use PI new functionality then you need to upgrade PI system, if you don't use the new functionality then ECC can be higher version than PI, check below sap note for more details.

      1043047 - Compatibility of XI/PI in the system landscape


      • If the application does not use any new XI/PI functionality, it is technically possible to run an application system with a higher release than the PI system. For this reason, the combination with an older PI system can only be released by the applications themselves in addition to the general rule. These specific releases will be listed in note 1388258.

      Regards,

      Praveen.