Skip to Content

WS-RM configuration No Business Application exists for Business Application ID error

Dear Experts:

I'm working on WS-RM configuration, between ERP and TM. That means Integration without PO.

I follow the steps on the guide WS/RM Integration Guide for SAP Transportation Management - Version 1.2

Everything looks fine and without errors, but when I try to release the integration scenarios configuration.

It shows the following error:

Services Registry Connection 'LP_CENTRAL' tested sucessfully. Start configuration of proxy 'CO_TMS_BUSINESS_DOCUMENT_FLOW' Try to create a logical port using local shortcut. No Business Application exists for Business Application ID "4D188A07A73F3088E10000000A04641F" Failed to create logical port for local shortcut. Try to create a logical port using Service Registry Assigned provider interface 'BusinessDocumentFlowTMInformationbyBusinessObjectR' 'http://sap.com/xi/TMS/UX' and business appl. ID '123AD7DB5D591ED682F8D48C8785CBA1' Search in services registry for matching endpoints Use profile name = 'ERPQAS300' version = '1' type = 'Central' UDDI error: Getting Bindings for IBC '123AD7DB5D591ED682F8D48C8785CBA1' for registry 'SR_CENTRAL' failed '': Application Error: IBC 123AD7DB5D591ED682F8D48C8785CBA1 no existe UDDI error: Getting Bindings for IBC '123AD7DB5D591ED682F8D48C8785CBA1' for registry 'SR_LOCAL' failed '': Application Error: IBC 123AD7DB5D591ED682F8D48C8785CBA1 no existe No matching endpoints found in services registry Failed to create a logical port using Service Registry. Try to create a logical port using WSIL Use profile name = 'ERPQAS300' version = '1' type = 'CENT' Target WSIL type SAP_6.40 Assigned inbound interface 'BusinessDocumentFlowTMInformationbyBusinessObjectR' 'http://sap.com/xi/TMS/UX' 2 service(s) determined using WSIL query Error in WSDL access: No WSDL: 'Se ha producido una excepción en Library-Handler' None of the WSDL URLs can be rerieved successfully No WSDLs with central profile were found for inbound interface 'BusinessDocumentFlowTMInformationbyBusinessObjectR' 'http://sap.com/xi/TMS/UX' Failed to create a logical port using WSIL Configuration of proxy 'CO_TMS_BUSINESS_DOCUMENT_FLOW' failed

Configuration of service group 'TM_ERP_ORDINT_BDFLW' failed

 

I´ve tested all cofigurations and everything looks fine and the consistence its ok.

Many thanks in advance for your inputs.

Carlos

Captura.PNG (35.9 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Best Answer
    Jun 16, 2016 at 01:59 PM

    Finally the problem was solved applying the note

    2316667 - Error while parsing an XML stream: 'undeclared namespace prefix'


    Many thnaks for your help!


    Add comment
    10|10000 characters needed characters exceeded

  • Jun 10, 2016 at 11:58 AM

    Hi Carlos,

    Have you checked this note 2254217 - Change Business Application ID of Domain System?

    Regards.

    Add comment
    10|10000 characters needed characters exceeded

  • Jun 15, 2016 at 03:01 PM

    Hello Iñaki,

    Many thnaks for your advice!!

    Same thing SAP recommends, but It didn´t work.

    I'll update this thread when I figure it out.

    Thanks!

    C

    Add comment
    10|10000 characters needed characters exceeded