Skip to Content
-1

Issue in SLD registration (Netweaver 7.5)

Hi,

I am currently trying to register my netweaver abap system based on 7.5 to SLD.

In RZ70, i am getting below informtion, when trying to register into SLD.

SLD DS Start Program

1: MG1AS01_MG1_01: No data collectors exist

0: MG1AS01_MG1_01:

0: MG1AS01_MG1_01: Used RFC destination: SLD_UC

0: MG1AS01_MG1_01: RFC call successful

0: MG1AS01_MG1_01: 0: MG1AS01_MG1_01: No HTTP(S) destination is configured to transfer data.

0: MG1AS01_MG1_01:

0: MG1AS01_MG1_01: Existing periodic jobs removed.

0: MG1AS01_MG1_01: Program scheduled: 20170208 230906.

1: MG1AS01_MG1_01: Event-driven job already exists; scheduling not necessary.

Please suggest.

Regards,

Shyam

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Sep 11, 2017 at 12:06 PM

    Hi,

    We've managed to solve the same issue today. It turns out, that, just as the error message states ("No data collectors exist"), there were no data collectors defined in RZ70.

    You don't see it right after opening RZ70 transaction. You must also click the icon next to "Delete Background Job", called "Show Hidden Details". It displays additional section at the bottom, called "Data Collection Programs". In our case, it turned out that this section was completely empty, no data collection programs were defined... That was the reason of our problem.

    The solution was to click one of the icons on the right side of "Data Collection Programs" section (looks like a green Z letter), called "Transfer". After clicking, it asks You:

    "Do you want to add data collection programs from the database to the list?".

    We simply chose "Yes" and it added all the data collection programs to the list! Now we just had to tick "Active" field beside each program and there You go- "Data collected successfully". Problem SOLVED.

    Regards,

    Adam

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 09, 2017 at 08:12 AM
    -1

    Hi Sriram,

    Issue resolved.. Thanks for your help..

    Add comment
    10|10000 characters needed characters exceeded

    • Moderator action: I am "unaccepting" this as best answer, because it is no answer at all. Instead, I suggest others look at Adam Szczurowski's answer below, as likely that was the solution for the OP as well.

  • avatar image
    Former Member
    Feb 08, 2017 at 12:12 PM

    Hi Shyam.

    1. I thing you have to define the central SLD url or host name of the central SLD system(either PI/XI or Solution Manager).

    2. Check the SLD confutation link http://www.sapbasis1solution.com/rz70-sld/

    BR

    SS

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Sriram,

      The above link is for older version of Netweaver. I am working on Netweaver 7.5. There are no option to select Program name.

      When i am executing after entering the sld details, it is not executing the programs for sld registration and giving error that "No data collectors exist".

      : No data collectors exist : : Used RFC destination: SLD_UC : RFC call successful : : No HTTP(S) destination is configured to transfer data. : : Existing periodic jobs removed. : Program scheduled: 20170214 173702. : Event-driven job already exists; scheduling not necessary.

  • avatar image
    Former Member
    Feb 21, 2017 at 07:13 AM

    Hi Shyam.

    Refer the SAP Note 2188401.

    BR

    SS

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 25, 2017 at 09:07 PM

    For NW 7.5 check SLD log. Below note fixed sync issue for me.

    2497068 - Comparison method violates its general contract in SLD Log

    Add comment
    10|10000 characters needed characters exceeded