Skip to Content
0

IE 11 MSS - Reporting - HRMSS_OADP_REPORTING - Not displaying

Feb 08, 2017 at 11:01 AM

276

avatar image
Former Member

Hi All, have just upgraded to Enterprise Portal 7.5 and during testing noticed MSS Reports are give a blank page in IE 11. Chrome/Firefox works 100%, so I know its not a report configuration issue.

Have setup two framework page with one with a blank document mode and one with IE=5, IE=EmulateIE7 (as per SAP Note 2016845). Standard SAP HTML GUI pages load correct with the blank document mode, but for MSS >> Reports (HRMSS_OADP_REPORTING), the page loads (see the SAP GUI logo) but no ITS report displays. Have tried the following:

Two different frameworks as described above;

Changed iView setting for lpd_start_transaction:

---Launch - display in separate headerless portal window (standard mode);

---Quick or Standard (tried both);

---Hand of browser doc mode parameter (on and off);

---Application parameters (tried blank or sap-ie-edge or sap-ie=EmulateIE8).

Any help here would be appreciated. Regards Brian

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Fabio Sarmento
Mar 09, 2017 at 04:28 PM
0

Hi guys,

Check the sap KBA 2395988;

Regards,
Fabio

Share
10 |10000 characters needed characters left characters exceeded
Matt Fraser
Feb 28, 2017 at 07:08 PM
0

Hi Brian,

I've just been going through a similar ordeal, trying to get the IE browser document modes correct after upgrading our portal to 7.5. It is solvable! You might have a look at https://answers.sap.com/questions/93285/webgui-standards-mode-with-internet-explorer.html where someone else has been dealing with a similar issue, and I wrote up what I did that worked for me in the answers (I can't say if it's the solution for the OP of that question, however).

What is your backend release? In our case, we're still using NW 7.01, but that turned out not to be an impediment. Double-check your backend kernel patch level. We're using kernel 722 pl221, and it's working fine. I believe it should work with kernel 721 as long as your patch level is at least 419.

Are you using the Ajax Standards Mode framework page? Check Note 2311707 for details about to set that, if you're not sure.

In your backend, in SICF, have you set your webgui service with the GUI Configuration parameter ~WEBGUI_NEW_DESIGN=1? Note that you may need to apply fixes from Notes 2007142 and 2140417 to make this parameter work correctly. This could involve manually editing details in table IACFL.

For your MSS Launchpad reports, as well as any WebGUI-based reports, this should be all you need to do. However, you may also need to set the default document mode for AppIntegrator if you use IAC iViews to launch backend transactions. I'm not aware of a Note describing this procedure, but from NetWeaver Administrator, go to Configuration -> Infrastructure -> Application Modules, select com.sap.portal.appintegrator, component Common_Configuration, and change property Default value for Browser Document Mode parameter to "edge" (it defaults to "EmulateIE8").

Meanwhile, take out the "sap-ie=" parameter from your iView, leave "Hand off browser document mode" set to on, and don't launch it in a separate window (unless you really want to, but this shouldn't be necessary). In other words, blank out document mode everywhere else that I didn't just mention above.

Cheers,
Matt

Share
10 |10000 characters needed characters left characters exceeded