Skip to Content

SAP HANA SPS 12: hdbroles doesn't work

Hi Experts,

we don't know why, but we don't get the .hdbroles within the new container to work.

We can build them without any problems. But if we try to grant the roles to anyone, it doesn't work.

We created this tinyworld sample. Maybe one of you wants to try it by his own. We tried it with hana studio and with the new webide but no difference, without that the error msg are not the same.

{

  "role":{

  "name": "tinyworld.tinydb::cdstinyworld",

  "object_privileges":[

  {

  "name": "tinyworld.tinydb::tinyf.country",

  "type": "TABLE",

  "privileges": [ "SELECT" ]

  }

  ]

  }

}

Could not modify user 'Dummy'. Could not grant role tinyworld.tinydb::cdstinyworld Role tinyworld.tinydb::cdstinyworld does not exist

21:06:54 (Security Editor) Changing 'Dummy' user failed:
404 - Granting ROLE 'tinyworld.tinydb::cdstinyworld' failed: invalid role name: tinyworld.tinydb::cdstinyworld: line 1 col 7 (at pos 6)

I had this problem also in SPS11 but was in hope that this problem would be solved with SPS12 for us . But it doesn't work either.

This issue is really a big problem for us, because we aren't able to get an access from outside via ETL to our hdi container (tables). 😔

I know, it should work. I saw this excellent video by Thomas Jung and I think I watched it more than thousand times to find out, where I missed a step.

DEV602 WebIDE Ex2 - Database Development - YouTube

Pls., any help would be greatly appreciated.

system.PNG (32.4 kB)
web.png (19.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Jun 06, 2016 at 10:41 AM

    If someone could send me any documentation about .hdbrole within a container that would be really helpful!

    Thanks a lot!

    Maybe I should mention that I used the same structure of hdbrole as Thomas Jung did in his video.

    DEV602/dev602.hdbrole at master · I809764/DEV602 · GitHub

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      I got helpful response from SAP.

      "Proposed solution alternatives:

      - Update HANA Studio

      - Grant the role via SQL: GRANT "<HDI container schema>"."Vorlagedb.roles::cdsTables" TO User"



      In my case, I had to update hana studio. This solved this described problem.

      Thank you!