Skip to Content
author's profile photo Former Member
Former Member

Crystal Reports Server XI Installation Issue

Hi,

I am busy installing Crystal Reports Server XI running on a Windows 7 64 bit unit. The installation progresses very well until it gets to a point where it just seems to stop and it never goes beyond that point. It just does the following and it has been standing there for hours.

"Time remaining: 4 minutes".

What I've tried so far :
1.) Restarting and trying the installation again.
2.) I've checked the application and system logs, but no information is available as to why this issue might be occurring.
3.) Disabled anti-virus

4.) Ran the Setup.exe as administrator.

Any idea on how I can get it to complete the installation ?

[EDIT] I found some sort of log file but I don't know if it will be of use. It had a line with an error code within it :

Installation success or error status : 1602

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 12, 2016 at 10:39 AM

    Hi,

    I solved the issue, and I made a summary on how below. Please note that this applies to my situation and doing some of these changes are a bit risky. Use at own risk 😉

    1.) OS = Windows Server 2008.
    2.) Added each service to DEP manually.
    3.) Set each service exe to compatibility mode "Windows Serer 2003...".

    4.) Edited registry - removed NTLMSSP dependency entry for each BOBJ* service.

    5.) create database if not exist:

    mysql -u USERNAME -p

    <enter password>

    CREATE DATABASE YOURDATABASENAMEHERE;

    5.) configure CCM:

    open "svcmgr.eke" aka Central Configuration Manager

    CCM:

    >Central Management Server

    >Specify CMS Datasource

    >MySQL

    > <enter mysql access details>

    CCM:


    6.) start CMS

    (or)

    6.) recreate the connection data for database and then start CMS

    7.) If you have issue logging into with username / password and Enterprise authentication :

    a.) CCM > stop CMS

    b.) access mysql :

    mysql -u USERNAME -p

    <enter password>

    #check for following line and then delete if exist

    SELECT * FROM CMS_InfoObjects5 WHERE (ObjectID = 12);

    DELETE FROM CMS_infoObjects5 WHERE (ObjectID = 12);

    c.) start CMS

    booyah

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 03, 2016 at 02:08 PM

    This software has been out of support for over 5 years and was never designed to run on modern operating systems.

    Having said that, I would do a couple of things to try to get this installed (no guarantees this will work):

    1. Turn off the anti-virus and firewall on the server for the duration of the installation.

    2. In the Control Panel go to System and Security (category view) >> Action Center >> Change User Account Control settings and set User Account Control to "Never notify".

    3. Right-click on the installer and select "Run as Administrator".

    If that doesn't work, righ-click on the installer and select "Troubleshoot compatibility" and set it to run as if it were an earlier OS. You may also have to do this for all of the .exe files that are part of the system after the install.

    If none of that works, you're going to have to upgrade to CRS 2013 or CRS 2016.

    -Dell

    Message was edited by: Dell Stinnett-Christy

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 03, 2016 at 06:33 PM

    First of all you should not install Server on Windows7 machine. You need to install on Server OS only

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.