Skip to Content
avatar image
Former Member

Error during SAP system rename

Hello,

I am facing following error during a system rename activity. I am in phase of rename of database instance. Our database is 11.2.0.4 on Linux x86-64.

<html> <head> </head> <body> <p> An error occurred while processing option <i>System Rename > Distributed System > System Rename for Database Instance( Last error reported by the step: The JVM reports an exception during execution of class ( com.sap.sdt.ins.component.ora_clone_obr.AdaptControlSqlFile ) and function executeStepClass. DIAGNOSIS: The reported error message from JVM is: java.io.FileNotFoundException: File not found: /tmp/sapinst_instdir/NW70/SBC/DISTRIBUTED/DB/CONTROL.SQL

        at com.sap.sdt.ins.filercopy.db.ora.RenameDatabase.adaptControlSqlFile(RenameDatabase.java:2320)

        at com.sap.sdt.ins.component.ora_clone_obr.AdaptControlSqlFile.execute(AdaptControlSqlFile.java:53)

.)</i>. You can now: </p> <ul> <li> Choose <i>Retry</i><br>to repeat the current step. </li> <li> Choose <i>Log Files</i><br>to get more information about the error. </li> <li> Stop the option and continue later. </li> </ul> <p> Log files are written to /tmp/sapinst_instdir/NW70/SBC/DISTRIBUTED/DB. </p> </body></html>

Following is the list of *.sql file

[root@saplgrddb DB]# ls -ltr *.sql

-rwxrwxrwx 1 root   sapinst   20 May 26 08:01 ora_stmt_scr_tmp.sql

-rwxrwxrwx 1 grdadm dba     1319 May 26 08:01 rename.sql

-rwxrwxrwx 1 grdadm dba      476 May 26 08:01 recover.sql

-rwxrwxrwx 1 root   sapinst  125 May 26 08:01 run_rename.sql

-rwxrwxrwx 1 root   sapinst   38 May 26 08:01 run_recover.sql

-rwxrwxrwx 1 root   sapinst  150 May 26 08:01 run_cntrl.sql

-rwxrwxrwx 1 root   sapinst   56 May 26 08:01 run_openResetLogs.sql

-rwxrwxrwx 1 root   sapinst  854 May 26 08:01 checkScript.sql

-rwxrwxrwx 1 root   sapinst   23 May 31 02:38 ora_scr_tmp.sql

[root@saplgrddb DB]#

Any idea how this error can be resolved. From where I can get control.sql?

Thanks,

Dnyandev

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Jun 01, 2016 at 09:57 AM

    Hi Dnyandev.

    The file is missing or without the correct permissions, please go to the Install_Dir and copy the file.

    Please also take a look at this:

    http://sapassets.edgesuite.net/sapcom/docs/2015/07/3009f6c0-5b7c-0010-82c7-eda71af511fa.pdf

    Regards.

    Osvaldo Dias Ferreira

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Osvaldo,

      The file is not present. From where I should copy it? You are asking to copy from Install_Dir but I am already in installation directory  sapinst_instdir which was created by sapinst.

      Thanks,

      Dnyandev

  • Jun 01, 2016 at 10:44 AM

    In fact the system is looking for /tmp/sapinst_instdir/NW70/SBC/DISTRIBUTED/DB/CONTROL.SQL and you are looking for *.sql files in lower case.

    First check if the database has been renamed to the target SID. If yes try to start the database and see if the database starts with the new SID.

    If yes then create a file called CONTROL.SQL in the /tmp/sapinst_instdir/NW70/SBC/DISTRIBUTED/DB location and add STARTUP; to it

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Dnyandev,

      - Create the CONTROL.SQL file

      - open the CONTROL.SQL file and type  "exit;" (without double quote)

      - Retry the steps on SWPM

      With Regrads

      Ashutosh Chaturvedi

  • avatar image
    Former Member
    Jun 02, 2016 at 06:23 AM

    Hello Dynandev,

    A couple of things some of which have already been covered.

    1. Running stuff like SWPM out of /tmp is never a good idea.

    2. SWPM can't find the file CONTROL.SQL. As already pointed out this is UPPERCASE.

    Try the following to see if you can find the file.

    $ cd /tmp

    $ find . -name CONTROL.SQL

    3. You have tried to start the DB and clearly you have a problem identifying control files which one could reasonably assume would have been created by the CONTROL.SQL.

    Try and find any file that contains the statement "create controlfile"

    $ cd /tmp

    $ find . -type f -exec grep -il "CREATE CONTROLFILE" {} \;

    Please come back with the info from the above. In the worst case you'll have to manually create the controlfile.

    KR,

    Amerjit

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Reagan Benjamin

      Hi Reagan,

      I removed REUSE and used only SET, but still same error.

      ERROR      2016-06-02 05:31:23.680 (root/sapinst) [CInstallerCallBackImpl.cpp:259] id=ind-rel.ind-os.ora.sqlStatementFailed errno=CJS-00084

      SQL statement or script failed. DIAGNOSIS: Error message: ORA-01503: CREATE CONTROLFILE failed

      ORA-01161: database name MCS in file header does not match given name of GRD

      ORA-01110: data file 2: '/oracle/GRD/sapdata1/sysaux_1/sysaux.data1'

      ORA-01507: database not mounted

      FOllowing is the initSID.ora file

      saplgrddb:oragrd 53> more initGRD.ora

      MCS.__oracle_base='/oracle'#ORACLE_BASE set from environment

      *._awr_mmon_deep_purge_all_expired=TRUE

      *._B_TREE_BITMAP_PLANS=FALSE

      *._fix_control='5099019:ON','5705630:ON','6055658:OFF','6120483:OFF','6399597:ON','6430500:ON','6440977:ON','6626018:ON','6972291:ON','7168184:OFF','8937971:ON','9196440:ON','9495669:ON',

      '13077335:ON','13627489:ON','14255600:ON','14595273:ON','18405517:2'#SAP_112043_201408 RECOMMENDED SETTINGS

      *._IN_MEMORY_UNDO=FALSE

      *._INDEX_JOIN_ENABLED=FALSE

      *._ktb_debug_flags=8

      *._mutex_wait_scheme=1

      *._mutex_wait_time=10

      *._OPTIM_PEEK_USER_BINDS=FALSE

      *._optimizer_adaptive_cursor_sharing=FALSE

      *._optimizer_extended_cursor_sharing_rel='NONE'

      *._OPTIMIZER_MJC_ENABLED=FALSE

      *._optimizer_use_cbqt_star_transformation=FALSE

      *._optimizer_use_feedback=FALSE

      *._securefiles_concurrency_estimate=50

      *._SORT_ELIMINATION_COST_RATIO=10

      *._TABLE_LOOKUP_PREFETCH_SIZE=0

      *.audit_file_dest='/oracle/GRD/saptrace/audit'

      *.compatible='11.2.0'

      *.control_file_record_keep_time=30

      *.control_files='/oracle/GRD/origlogA/cntrl/cntrlGRD.dbf','/oracle/GRD/origlogB/cntrl/cntrlGRD.dbf','/oracle/GRD/sapdata1/cntrl/cntrlGRD.dbf'

      *.db_block_size=8192

      *.db_cache_size=2899102924

      *.db_files=1000

      *.db_name='GRD'

      *.db_recovery_file_dest='/oracle/GRD/oraflash'

      *.db_recovery_file_dest_size=30000M

      *.diagnostic_dest='/oracle/GRD/saptrace'

      *.event='10027','10028','10142','10183','10191','10995 level 2','31991','38068 level 100','38085','38087','44951 level 1024','64000 level 25'#SAP_112047_201508 RECOMMENDED SETTINGS

      *.FILESYSTEMIO_OPTIONS='setall'

      *.log_archive_dest_1='LOCATION=/oracle/GRD/oraarch/GRDarch'

      *.log_archive_format='%t_%s_%r.dbf'

      *.log_checkpoints_to_alert=true

      *.max_dump_file_size='20000'

      *.open_cursors=2000

      *.optimizer_index_cost_adj=20

      *.parallel_execution_message_size=16384

      *.parallel_threads_per_cpu=1

      *.pga_aggregate_target=3865470566

      *.processes=150

      *.query_rewrite_enabled='false'

      *.recyclebin='off'

      *.remote_login_passwordfile='exclusive'

      *.remote_os_authent=true

      *.replication_dependency_tracking=false

      *.sessions=300

      *.shared_pool_size=2899102924

      *.star_transformation_enabled='true'

      *.undo_tablespace='PSAPUNDO'

      saplgrddb:oragrd 54>