Skip to Content
avatar image
Former Member

Lumira cannot consume SAP gateway service

Hi there,

In Lumira, I create a dataset by choosing source 'Query with SQL' and 'Generic OData 2.0 - OData Connector'. I enter the URI I get from SAP gateway client. The URI is like:

https://server:port/sap/opu/odata/sap/C_ODITEM_QUERY_HOME_CDS/. Then I enter the my user, my password and the proxy. An error message shows:

Actually the URI is fine if I use in Chrome. The issue seems to be an authentication issue. And I tried to add the my user and password into the URI however not work https://user:password@server:port/sap/opu/odata/sap/C_ODITEM_QUERY_HOME_CDS/

I find the corresponding information in this thread: https://archive.sap.com/discussions/thread/3941514

Does anyone have ideas for this issue?

Thank you.

Clark

0208.png (9.0 kB)
Add comment
10|10000 characters needed characters exceeded

  • Do you have access to the OData service in S4? I'm not sure how the security works in S4 - it would be nice to see if a security trace could be done on your ID when you try to logon to the service. In ECC the transaction is STAUTHTRACE

  • Former Member Tammy Powlas

    Hi Tammy,

    I have not used this tool. So I have some try. I set the system wide trace on and activate the trace.

    When I use Lumira to acess the metadata, no trace is available.

    When I use Chrome to acces the metadata, some trace like below. The metadata can successfully show in Chrome.

    Kind Regards,

    Clark

    020801.png (94.1 kB)
  • It appears you are missing access in the SAPLSTR9 program; I recommend asking your S4 security person to assist. I'm not sure it will fix the problem entirely but once the security issues are fixed it can be ruled out as an issue.

  • Get RSS Feed

0 Answers