Skip to Content
avatar image
Former Member

DMS Workflow: Problems in sending mails

Hello friends !

Our workflow is supposed to send an external mail (to lotus notes) each time a new document is created. (workflow has several steps but the problem exists in this particular first step).

We extended the Business Object 'DRAW' and added our own 'z-methods'. The problem is whenever we create the document, workflow is triggered and mail can be seen in SCOT but its not picking up the recipient's email id.

In our function module which is called by the z-method, email id is picked up on the basis of login userid. when we test the function module independently(called by our z-method), same thing occurs but as soon as we debug it, it runs smoothly and it also picks up the recipient's id and mail is also triggered. So the desired result is obtained only during debugging and not normally (while debugging it can be seen clearly that all tables passed to SO_OBJECT_SEND_API1 are properly filled in. as soon as we come out of debugging mode we find mail to proper recipient is sent).

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • avatar image
    Former Member
    Apr 14, 2009 at 07:43 PM

    did you get any solution for your problem ???

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 15, 2009 at 06:44 AM

    This message was moderated.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 17, 2009 at 06:01 AM

    hi

    please check in SAP service market some notes to be applied for this

    SO_OBJECT_SEND_API1

    Add comment
    10|10000 characters needed characters exceeded