Skip to Content
author's profile photo Former Member
Former Member

Alerts not triggered/sent SBO 9.2.

Hi all,

I have setup 3 User Alerts, none of them is triggered or sent.

I've checked the following:


  1. The SQL Queries do return results
  2. The Alerts have a SQL Query attached
  3. The Alerts are Active (they have been unticked and reticked)
  4. The user who created the alert and query is a superuser
  5. The user is signed into SAP
  6. The Alerts do not return a NULL value in the first column
  7. The Alerts are not based on a query which includes comments such as "/*...--...*/"
  8. The SQL queries do not contain an IF statement
  9. All alerts have names, and those are excluding special characters such as (*)

SBO VERSION: SAP Business One 9.2 (9.20.003) PL: 00 (64-bit)

Any ideas?

Any help is much appreciated.

Thanks

Ana

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

7 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Sep 05, 2016 at 12:31 PM

    This is resolved now!

    Even though I was updating the settings (connection setting and database) of the Job Service - Mailer in the service manager, the settings were not saved correctly. By updating the setting in the SLD, and started the service from there, it works OK.

    It is needed:

    - AlertScv user has to be a superuser (or have the appropriate authorizations)

    - AlertScv user has to be selected in the Alert

    - Job Service - Mailer has to be configured using the link in the SLD (at least in my case)

    Thank you all for your help

    Regards

    Ana

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 20, 2016 at 03:43 PM

    9.2 is using a new service called Job service, make sure it is running.

    before 9.2, alert will rely on user's login to trigger, but in 9.2, it is not.

    Frank

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 21, 2016 at 01:03 AM

    Hi,

    Please check following,

    1. In alert management, AlertSvc is selected.

    2. Job service is running and selected correct database.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 12, 2016 at 10:31 AM

    Hello everyone,

    i was faced the same problem after upgrade to 9.2 PL 03

    after adjustment of authorisations for AlertSvc (at least for send message and querry generator) the alerts are being triggered again. Altenative you can define the Alert Svc as super user.

    Hope this helps.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 24, 2016 at 10:26 AM

    Hi Ana,

    Have you activate log for Alert in ALRTCATDEF

    -> Settings -> Configuration -> Write log

    Also add the the used for which email configuration is completed in SU01.

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on May 25, 2016 at 03:07 PM

    Please attach your SQL query to check.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jun 24, 2016 at 06:58 PM

    I'm having the same issue. The alerts are enabled but never actually go off. I even tried a simple query and it still doesn't work:

    SELECT 'TEST' from dummy


    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.