Skip to Content
0
Former Member
May 17, 2016 at 01:59 AM

SAP GUI java 740 for aarch64 linux

446 Views

Hello,

Is SAP GUI JAVA 740 for aarch64 linux?

I got the error like this:

----------------------------------------------------

Attempt to load shared library

/home/oem/SAPClients/SAPGUI7.40rev6/bin/libJPlatin64.so failed.

The library file exists, so either the program has insufficient privileges to

access the library or the library is not loadable by the shared object loader.

Please recheck the system requirements for your operating system and make sure

all required libraries are installed.

Technical Details

java.lang.UnsatisfiedLinkError: /home/oem/SAPClients/SAPGUI7.40rev6/bin/libJPlatin64.so: /home/oem/SAPClients/SAPGUI7.40rev6/bin/libJPlatin64.so: Cannot open shared object file: no file or directory (Possible cause: can't load AMD 64-bit .so on a AARCH64-bit platform)

----------------------------------------------------

About libJPlatin64.so:

#readelf -a libJPlatin64.so

ELF head:

Magic: 7f 45 4c 46 02 01 01 00 00 00 00 00 00 00 00 00

Class: ELF64

Data: 2's complement, little endian

Version: 1 (current)

OS/ABI: UNIX - System V

ABI Version: 0

Type: DYN (shared object file)

Machine: Advanced Micro Devices X86-64

Version: 0x1

Entry point address: 0x90b30

Please answer if anyone is aware of this.

Thanks in advance.