Skip to Content
0
Former Member
May 11, 2016 at 02:04 PM

SM12 lock Issue-Not getting released automatically

9478 Views

Hello Friends

One of my customer facing SM12 lock issue which occurs only in night time.During Day hours issue does not counter us.Once its get locked he has to delete the lock entry in SM12 and repeat. Below is the inputs from customer.

  1. A user logs into the system for a transaction
  2. A Dialogue opens
  3. The moment the dialog opens the relevant database table gets locked
  4. there are 2 option for the user either he updates or he cancels the dialogue
  5. If he Cancels the database lock should get release
  6. If he updates then after updation the data base lock should get released

What were the areas where we have been finding difficulty:

In case 5 when user comes out wirhout updating the data base lock doesn't get released, so we have to release it through SM12

In case 6 what was happening the updation happens in two step update 1 and update 2. So the same was failing either in updation 1 or updation 2 and therefore the data was staying locked. In this case we have to either using SM13 update the record and in cae of error delete the record and in such case the data base lock would get released automatically and we were not required to use SM12.

What appears to have been solved?

Since last 5 days there hasn't been a single case were any updation has failed.

What is still pending?

Case 5, i.e. when user cancels a transaction or dialogue and comes out of a transaction and again re-enters for a new record the system says data locked by the same user....In such case we manually using SM12 have to delete the lock.

Case 6 many times most update the database lock is not geting released and when the user logs in again and want to work in the same sales order he gets a message that the document is locked. In such case when we see the SM12 log we find the old set and new set both as locked. So when we delete the lock of the old set the lock of new set automatically clears and therefore the log gets cleared.

Does the problem have a pattern?

The problem primarily occurs after 9 PM at night and happens till 8.00 AM of next morning and doesn't appear in day time when the system is used by at least 60 concurrent users.

The problem occurs with VL01N transaction mainly and rarely with MIGO transaction. The problem doesn't occur with ZGATEPASS_In AND ZWEIGHBRIDGE. These transaction occurs anything between 50 -100 times during the period mentioned.

The problem of locking occurs once or twice in a sequence of entry i.e. if 10 vehicles enter for delivery (VL01N) it will get locked for 2 vehicles and then 8 vehicles will go without any problem again when the next sequence starts it may happen with the first one or with some subsequent ones and then it stays fine.

With the details shared I would like to mention that though it may appear the problem partly is solved

Below is the SM21 log entry.

10.05.2016 22:29:01 prod21_EXP_00 DIA 003 600 XXXXXXXX @5C\Qvery high priority@ GEO Lock entry deleted manually: LIKP E 10.05.2016 22:29:01 prod21_EXP_00 DIA 003 600 XXXXXXXX @5C\Qvery high priority@ GEO Lock entry deleted manually: MARC E 10.05.2016 22:29:01 prod21_EXP_00 DIA 003 600 XXXXXXXX @5C\Qvery high priority@ GEO Lock entry deleted manually: VBAK E 10.05.2016 22:32:38 prod21_EXP_00 DIA 002 600 XXXXXXXX @5C\Qvery high priority@ GEO Lock entry deleted manually: LIKP E 10.05.2016 22:32:51 prod21_EXP_00 DIA 001 600 XXXXXXXX @5C\Qvery high priority@ GEO Lock entry deleted manually: MARC E 10.05.2016 22:32:51 prod21_EXP_00 DIA 001 600 XXXXXXXX @5C\Qvery high priority@ GEO Lock entry deleted manually: VBAK E

Kindly Provide us the Inputs from your end where issue is pointing so that we can resolve quickly.

Regards

Pankaj