Skip to Content

Object using in query filter on timestamp getting result only for date not for timestamp.

HI

When I try to create a report with time stamp in query filter , not even getting data even the date and time exists in database.

Below Is the detailed analysis.

1. created a webi report with timestamp objects.

2. Apply query filter on timestamp object.

3. when I check In auto generated sql it only pick date part from the query filter but not timestamp.

4. Because of the above issue we are not getting expected results.

Webi Auto Generated SQL

Select Table.row_eff_ts

From Table

WHERE

Table.row_eff_ts IN ( {d '2015-09-17'} )

It picks only date part but not entire timestamp. But I need entire timestamp in WHERE clause. Please, suggest me a solution

Timestamp.png (4.8 kB)
Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Posted on Apr 22, 2016 at 08:39 AM

    what is datatype of this object in universe date or datetime?

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 22, 2016 at 09:07 AM

    Hi Jagadeesh,

    What is the data base on which you are creating this report?

    Check the corresponding prm file for USER_INPUT_DATE_FORMAT parameter. I think it is date type data type is date in the prm file rather than timestamp.

    example location of prm for oracle database

    ..\Business Objects\BusinessObjects Enterprise 12.0\win32_x86\dataAccess\connectionServer\oracle\oracle.prm

    Add a comment
    10|10000 characters needed characters exceeded

    • Thanks Divya.

      We tried to replace the date format {\d 'yyyy-mm-dd'} into timestamp {\ts 'yyyy-mm-dd hh24:mi:ss.us'}. But it is not working.

      when we check in webi generated sql, in WHERE clause we are getting like

      objectname = {t17 '2016-04-53 12:00:00'} instead of

      objectname = {ts '2016-04-25 12:00:00'}.

      Could you please tell me the timestamp format in Postgresql to set for USER_INPUT_DATE_FORMAT parameter.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.