Skip to Content
avatar image
Former Member

process hdbxsengine not running

Hi everyone

My hana can't start because suse11 power off by inspection of the electric.

Error information : FAIL: process hdbxsengine HDB XSEnging not running

What information do you need to tell me that I will upload .

Thanks!

Message was edited by: Tom Flanagan

1234.png (5.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • avatar image
    Former Member
    Apr 20, 2016 at 06:54 AM

    Hi Lion

    It looks like your OS got crashed. First please do a clean restart of DB after running following command if possible

    HDB stop

    cleanipc <SYS NR> remove

    HDB start

    If the same issue exists, you can upload xsengine_<hostname>*.trc from

    /usr/sap/<SID>/HDBXX/<host>/trace to find the root cause.

    Thanks

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      I did try the cleanipc which I saw in another post.  It didn't work. I eventually reinstalled my secondary, then my primary, then restored from a recent backup.  Oddly the backup had volumes 0_1, 1_1, 2_1 and 4_1.  I was fairly nervous, but it worked to get me to the state I was at prior to configuring pacemaker.  It's a short putt from there.

      Thanks much for the support.

  • Apr 20, 2016 at 08:17 AM

    Hello Lion,

    Please check the trace and alert files related to xsengine under directory /usr/sap/<SID>/HDB<instance numer>/<hostname>/trace to find the possible reason.

    Regards,

    Ning

    Add comment
    10|10000 characters needed characters exceeded

    • Have you thought about reinitializing the Xsengine? This worked for me before on a test system. I Wouldn't recommend this if you have applications using it though. If they are log segments that are missing, You have to find where they moved. Check if  log segment is truncated, if it is then you could "touch" log segment to create a dummy but I would only do this if the log is truncated.