Skip to Content
author's profile photo Former Member
Former Member

Bex queries not rendering properly

Hi experts,

We have implemented bex queries using Bex analyzer iviews in portal. We are maintaining Document mode as Edge(Standards).

With this, bex queries are note rendering properly. The problem is for any bex report accessed from portal, in the filter screen,text in one column is overlapping on the next column.

When I pressed F12,it was Edge mode and when we try to change it to 5(quirks) the problem goes off i.e the reports are displaying properly.

Also we tried to maintain properties of the iview like Display in separate headerless portal window (standards) mode and the Document rendering mode property to standards,but none worked.

In some blogs in scn and in SAP note 2012705,I came across to check the support package and patch levels which are all maintained the same.

Don't know where the problem lies.

Render some help on this to resolve.

Thanks

Deepak

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Posted on Apr 19, 2016 at 11:52 AM

    Hi Deepak

    As per my understanding the issue you are facing is due to the rendering issue faced with Internet Explorer.

    According to your description you are forcing the application to render in Standards Mode, but when you change it to 5, it starts behaving in quirks and renders the report correctly.

    So you are forcing the document to a open up in a wrong rendering mode. Actually the reports requires quirks mode of rendering.

    Can you please refer to the below SCN document and carry each of the steps given in it.

    9 Steps to Solve Portal Rendering Issues in IE

    Mostly the above document will solve the issue you are facing.

    Regards

    Santarshi Samanta

    Follow Santarshi Samanta

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Samanta,

      We have followed all the steps mentioned in that link.

      We have implemented Standards mode(IE=Edge) value since it supports UI5 application.But the BW reports (bex queries) are not working properly in Standards mode. This is the problem.

      As per our requirement we are going to use Edge i.e standards mode only.

      Suggest some resolution on this scenario.

      Thanks

      Deepak

  • author's profile photo Former Member
    Former Member
    Posted on Apr 19, 2016 at 07:58 AM

    Hi,

    We have faced similar type of issue.

    please read the below note. Hope this problem will solve.

    1918315 - BICS v25 for NW 7.30+, Design Studio, Analysis Office & BI Platform


    Thanks

    Patrick

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 21, 2016 at 07:17 AM

    Hi Meghal,

    I followed the steps mentioned by you.

    1) created a page and assigned the browser document mode iview to the page and set its value to IE=5.

    2) Assigned the bex query to the page.

    3) assigned the page to a role.

    Same problem persists.

    Thanks

    Deepak

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 21, 2016 at 07:34 AM

    Even after creating changing the document mode value to IE=5 in the document mode iview and assigning it to the page,this value is not reflecting.

    When i press F12 and see the value of document mode under emulation tab,it is still

    Edge.

    This value is coming from the framework page. The framework page has the browser document mode iview whose property is set to
    IE=Edge.

    Is there any possibility to independently have the document mode value as 5 for BW reports alone and Edge value for UI5 applications alone?

    If anything please suggest.

    Thanks

    Deepak

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Nick Rankin

      Hi Nick,

      Thanks for your response.

      I understand your point but how do I do that?

      How can I access my bex analyzer iviews from standards portal framework page?

      Is there any property in the bex iview that needs to be changed?

      I have already changed the Hand over document mode paramater and launch property as mentioned by Samanta.

      Guide on this.

      Thanks

      Deepak

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.