Skip to Content
avatar image
Former Member

Issue with data binding on table

Hi Community,

I am experiencing some issue with data binding for table with similar value.

I created 3 table, each under a subform. The subform and and the table I set them to the same name.

When I tried to bind the table, there is no issue with Table 1. When I tried to bind to Table 2 and 3 the value does not appear.

The reason is all the 3 tables (part highlighted in yellow) get the data binding value from $.ServiceRequest.Item[*].ItemNetPrice.Amount or ItemNetPrice.Amount depending on the table binding.

When the Table 1 is bind, and the 2nd table is not, the value appears but it is incorrect order. Additionally, the 3rd table will also be getting similar value as table 2. May I know if there is an additional way to do this? Or is my approach is incorrect? If so, how could I solve this?

Many thanks.

The part highlighted in yellow is taking info from existing ALCD standard data binding value - Net Price Amount.

TableIssue.JPG (49.5 kB)
TableIssue02.JPG (32.1 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Apr 18, 2016 at 07:44 AM

    Hi! You should not bind three ui table elements to the same table in the data model $.ServiceRequest.

    Better you create three entities in the data model, with the same data, for example

    $.ServiceRequest1

    $.ServiceRequest2

    $.ServiceRequest3

    and bind each ui table to a different data model table.

    Let me know

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Alessandro,

      Thanks for the suggestion. How do I change the 3 entities because its standard data connection from c4c. I am currently using the standard form from c4c and the form is binded to ServiceRequest.xbo.

      Thanks!