Skip to Content
0
Former Member
Apr 15, 2016 at 02:25 PM

File permission generated by bcp utility

100 Views

Hello guys.

I already read some other forums and articles in the Internet, but nothing that I found helped me.

Could you please try to help me?

- There is an application job executing the bcp utility (with -e option) and inserting data into a table

- The permission of the file is being wrongly generated. It should be 644, but the file is created as 400

- The application team cannot read the file as they are using different Ids from the one used by the batch job

- We already tried to use the filemode option, change the umask to 022, change the OS Id to different groups, etc. None of them worked.

- The ASE version is 15.7 SP136

- The application team says the issue started happening after the upgrade from ASE 15.0.2 to 15.7

- Although this is just an ordinary error file, Customer want us to fix the issue as we're responsible for their environment. We could simply add a chmod command after the bcp and change the permission.

- I already connect to the Unix server using the Id used by the batch job and executed the bcp out command and the file was correctly generated (for both ASE V15 versions)

- The Unix team opened a PRM and already performed all the activities suggested by the 2nd level support

Do you guys have another suggestion?

Thanks.

Sergi