Skip to Content
avatar image
Former Member

Python under 15.5

Hi,

I am running version 15.5 of ASE and I wonder if it is possible to run python under this version ?

Regards,

Klas

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Apr 14, 2016 at 12:15 PM

    Hi,

    I can see from 15.7 in marketplace. If you check the link below they mentioned from installation of 15.0 so I assume it should be possible.

    Developing Python Application with Sybase ASE

    Probably just easier in 15.7 upwards.

    Johan

    Add comment
    10|10000 characters needed characters exceeded

    • Johan

      The document in the link you provided "Developing python Application with Sybase ASE" does not exist. I alerted the moderator about that but as usual SCN folks do not seem to be bothered by broken links.

      Avinash

  • Apr 19, 2016 at 02:47 PM

    Hi,

    Here is the documentation about SDK python module for ASE:

    http://infocenter.sybase.com/help/index.jsp?topic=/com.sybase.infocenter.dc01692.1570/doc/html/car1308847098623.html

    Required Components

    Access to an Adaptive Server database using the Python programming language requires these components:

    • sybpydb – extension module for the Python scripting language.
    • Open Client SDK – provides application development tools that allow access to data source, information application or system service.
    • DBCAPI – is a function library that acts as intermediate conversion layer between the extension module and the CT-Library.
    • CT-Library – (CT-Lib API) is part of the Open Client suite. CT-Library sends commands to Adaptive Server and processes results.

    Version Requirements

    For information about platform support, see the Software Developers Kit and Open Server Installation Guide for your platform.

    • Adaptive Server Enterprise – version 15.7 or later
    • Python installation – version 2.6 built-in threaded mode.
    • Open Client SDK – version 15.7 or later.

    For this module the ASE needs to be 15.7 or later to be supported.

    Regards,

    Ryan

    Add comment
    10|10000 characters needed characters exceeded