Skip to Content
avatar image
Former Member

Java support for BO 4.0

Hello Experts,

We are using BO 4.0 SP9 platform and only having Crystal reports as objects.

Currently we have java 1.6 on our server for which public support is already ended.

i have few questions:

1. can we get rid of java from server as we are only using Crystal Reports , No Webi..what is the recommendations..

2. If Java 1.8 is supported by current environment (4.0 SP9).

3. what would be recommendations related to Java upgrade with respect to our BOE platform..

thank you in advance!

Regards,

Devendra

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

4 Answers

  • avatar image
    Former Member
    Apr 13, 2016 at 07:23 AM

    Just to add We use Crystal Report 2011.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 13, 2016 at 12:28 PM

    Check the compatibility of JAVA Version for your BOBJ version from SMP.

    --Subbu

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 13, 2016 at 12:40 PM

    Devendra,

    The PAM for BI 4.0 w/SP09 states that it is supported but in limitations, see attached.

    Regards,

    Ajay


    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Apr 16, 2016 at 07:34 AM

    Hi Devendra,

    First of all BI 4.0 SP9 is supported with 6,7,8 and behaviour varies according to the Browser you are using.

    Below are the answers to your question :

    • There is no need to install JAVA on the server if you have specifically installed JAVA for BI. SAP BI comes with own java which is sapjvm and which is used to run servers, tomcat etc. So the java which are mentioned required on the client machine only because your browser uses java of OS which you download from oracle.
    • Java 8 is supported but browsers and limitations mentioned in the PAM guide above.
    • We always recommend customer to avoid use of VERY Latest version of Java released and it will have problems. You can use java which work fine with your environment which can be determined by only using it.

    Regards,

    Mahak

    Add comment
    10|10000 characters needed characters exceeded