Skip to Content
avatar image
Former Member

livecache cannot be started

Hello experts,

I cannot start livecache (7.7.07.50 on Linux) due to following errors:

dbmcli on LCD>db_online

ERR

-24994,ERR_RTE: Runtime environment error

20090,Check knldiag! Kernel exited with '1' before reaching ADMIN state

The database is in state "offline", but resources were found: pid file

found but

startup message from kernel:Core dump suppressed

dbmcli on LCD>show state

OK

No root pointer in mapping table

'RTECons_MemoryDumpMapping' instance could not be created

Failed to map memory dump files


I have tried to clear pids from below files (by mv LCD LCD.old) and then start.

/sapdb/data/pid/LCD

/sapdb/data/ppid/LCD


Cleared shared memory by:


/sapdb/LCD/db/pgm/dbmshm CHECK /var/lib/sdb/dbm/ipc LCD

/sapdb/LCD/db/pgm/dbmshm DELETE /var/lib/sdb/dbm/ipc LCD

I have also tried to delete folder /sapdb/data/wrk/LCD/rtedump_dir and

checked SAPNote 1283278.


Attached is knlmsg log.


Thank you for any advice.


Ivana



knlmsg.txt.zip (1.2 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

3 Answers

  • Best Answer
    Apr 08, 2016 at 01:07 AM

    Hi Ivana,

    Please attach diagpack.tgz after executing command below:

    dbmcli -d <dbsid> -u control,<password> diag_pack

    Best regards,
    James

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member James Zhang

      Hi James,

      based on SAP Notes I found out there was different number of data volumes and log volumes present on the server than in configuration. Command param_getvolsall showed 13 data volumes and 1 log volume but there were 21 data volumes and 2 log volumes on server. It means that by restore_param i "took away" data volumes from number 14. I reverted it as I described above.

      I have opened OSS message to SAP and they solved the issue. The cause was that parameters MirroredLogVolumeName002 and LogVolumeName002 were identical. So I set parameter MirroredLogVolumeName002 to different path than LogVolumeName002.

      Thanks a lot for help!

      Ivana

  • Apr 08, 2016 at 01:30 AM

    Hello,

    In the attached knlmsg log:

    <MSGL _NO="946096" _PROCESS="8506" _THREAD="0x213A" _TIME="2016-04-07 12:01:09.000">

    <MSG _NO="1" _TYPE="Error" _ID="20056" _COMP="RTE" _TEXT="Volume &apos;/sapdb/LCD/saplog/DISKL002&apos; already exists">

    <MSG_ARGS

    When you had log full situation, you decided to add log 2, again this is not correct solution for log full situation. Adding log volume 2 most probably did not work because of log full problem.


    Try following command

    dbmcli -d <SID> -u control,<password> db_offline

    param_restore 1

    db_warm

    db_online

    Regards,

    David

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 13, 2016 at 12:33 AM

    Glad to solve it, parameter restore should always be used carefully😊

    Add comment
    10|10000 characters needed characters exceeded