Skip to Content

new UI5 app not running on Launchpad (metadataLoaded error)

Hi,

I have created a UI5 app from the template (master-detail). I have done nothing to it other than add an index.html file. It runs fine in test against a Mock server or normal server but when I deploy to ABAP Repository (which it deploys successfully) it fails to run in the Launchpad

I just get a blue screen. in the Dev console I get the following error:

Uncaught TypeError: Cannot read property 'metadataLoaded' of undefined UIComponent.js:6

I've tried building in version 1.28, 1.32 and 1.34. The Gateway is running 1.34

I have not added anything to the template except the index.html (as our Gateway will not run without it), the code for the index.html is below:

<!DOCTYPE HTML>

<html>

<!-- IMPORTANT

This HTML file is meant for testing the application/component standalone, outside the Unified Shell.

Some integration functionality, personalization etc. will not be available when running standalone.

-->

<head>

<meta http-equiv="X-UA-Compatible" content="IE=edge" />

<meta name="viewport" content="width=device-width, initial-scale=1.0" />

<meta charset="UTF-8">

<title>ZHRT</title>

<script

id="sap-ui-bootstrap"

src="resources/sap-ui-core.js"

data-sap-ui-libs="sap.m, sap.ui.commons"

data-sap-ui-theme="sap_bluecrystal"

data-sap-ui-xx-bindingSyntax="complex"

data-sap-ui-resourceroots='{"ZHRT": "./"}'

>

</script>

<!-- Application launch configuration -->

<script>

sap.ui.getCore().attachInitEvent(function () {

var oComponentContainer = new sap.ui.core.ComponentContainer({

height : "100%",

name:"ZHRT"

});

oComponentContainer.placeAt("content");

});

</script>

</head>

<!-- UI Content -->

<body class="sapUiBody" id="content" role="application">

</body>

</html>

Can anybody tell me why this will not run please and how to fix it?

Thanks

Adam

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Apr 07, 2016 at 03:29 PM

    Hi,

    Can you post a screen shot of the tile and target mapping properties of the tile you have created for your custom UI5 app?

    Regards,

    Saurabh

    Add comment
    10|10000 characters needed characters exceeded

    • Hi,

      I have spoken to our SAP Gateway guy, he said that when we deploy, he can check the app via SICF and it fails in there with the same error, so it appears it isnt a targeting issue with the tiles.

  • avatar image
    Former Member
    Jul 27, 2016 at 10:39 AM

    Hi Adam,

    and what caused the issue?

    Regards, Peter

    Add comment
    10|10000 characters needed characters exceeded