Skip to Content
0

CDS - HANA Studio - Eclipse neon feature - Open Data preview View Parameters

Feb 07, 2017 at 12:04 PM

783

avatar image

Hi all,

probably someone could help me on this matter.

I can't run Open Preview Data for View with Parameters from HANA Studio.

Message is: Preview data is not available for view with parameters.

From ABAP workbench I tested

IF abap_true = cl_abap_dbfeatures=>use_features( requested_features = VALUE #( ( cl_abap_dbfeatures=>views_with_parameters ) ) ).

and is True.

Did I miss any packages?

Thanks a lot

10 |10000 characters needed characters left characters exceeded

Hi Rob,

This is indeed strange. I tried to reproduce the issue with a 750 SP02 system with ADT 2.68.6 but it seemed to work fine for me. Can you check if this is the only view that is showing the error or if all view with parameters are the having the same error?

Thanks and Regards,

Shyam

0

Hi,

all view with parameters. Can you show me your feature details? My ADT is 2.68.6 but the preview data component inside is 1.48.1. I don't know if it's correct. It comes with the whole package in eclipse.

Thanks a lot

Regards

0

Hi Rob,

It is the same as yours.

Can you open an OSS ticket providing your system connection details?

Probably we can take it from there and see where the issue is specifically for you.

Thanks and Regards,

Shyam

0
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Shyam Balachandran Feb 27, 2017 at 11:16 AM
1

Hi Rob,

From whatever I can deduce from the images you are trying to open Data Preview for 2 different entities.

For View with parameters , the data preview works only for the CDS View ( the name used in the DDL Source's define view statement ).

Data Preview does not work for the ABAP Dictionary View.

If you want to preview data for a view with parameters then you need to use the CDS View only. So either F8 ( same as "Run AS" -> Abap Application) on the Data Definition or Open With -> Data Preview on the Data Definition in the project explorer will work correctly.

The error message you are getting for Dictionary View is expected.

Thanks and Regards,

Shyam

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Shyam.

Thanks for reply. My question is why this error message raises only for CDS View with parameters.

CDS View with no-parameters works correctly.

If I understand what you say is that Data Preview, in CDS View with parameters, works only when I choose preview while We refear explicitly to the DDL Source View and not the Dictionary reference from the project explorer in SAP HANA Studio.

That's a strange behaviour but Ok.

Thanks for support.

Regards.

0
Florian Pfeffer
Feb 08, 2017 at 08:03 AM
1

What ABAP Development Tools version and what ABAP/NetWeaver backend version you are using? I assume that you are on a release which does not support the data preview for CDS views with parameters. It works at least with a NetWeaver >= 7.50 backend system and ADT >= 2.51 version.

Regards,
Florian

Show 5 Share
10 |10000 characters needed characters left characters exceeded

Hi Florian,

thanks for your reply. NetWeaver is 7.50 and ADT is 2.68.1

It seems strange to me cause is the last version I think and data preview is not available for view with parameters. For normal view with join is ok.

Regards.

Rob

0

Hm, looks strange. I tested it on a NW 7.50 SP02 system with the same ADT version you are using.

1

Well,

did I miss something in the declaration part?

@AbapCatalog.sqlViewName: 'ZVIEW_PARAM1_CDS'
@AbapCatalog.compiler.compareFilter: true
@AccessControl.authorizationCheck: #CHECK
@EndUserText.label: 'View CDS with parameters'
define view ZVIEW_PARAM1_CDS_DDL
    with parameters p_langu: abap.lang,
                    p_saving_rate: abap.dec(7,2),
                    p_ord_status: estak

I don't know..

It seems quite the same message that everyone receive from SE11 in GUI.

Thanks anyway.

0

The syntax is ok. What type has the estak data element?

0

ESTAK is type char1.

I've tried to change parameters type but no way.

More in detail, abap data preview component is

In case, how can I update only this component?

Thanks

0
Roberto Vacca Feb 22, 2017 at 08:43 AM
0

Hi Shyram,

I found the solution.

Data preview seems to work only from "Run AS" choosing Abap Application and with the focus on the Data Definition..

Instead, if I use Open Data Preview, with focus on the Workspace project, it doesn't work, showing the message I posted :

I don't know if it's a feature or a Bug. Let me know if you know it

Thanks for your help.

Regards.


Share
10 |10000 characters needed characters left characters exceeded