Skip to Content
avatar image
Former Member

Generic Data source based on LQUA table not working

Hi All,

A generic datasource was created to pull the data from table LQUA table.

the generic Delta has the field BDATU (last movement)

and the Delta extraction is defined as AIE

In the BW side, when the delta infopackage is running, after somedays, tha data does not match and I can imagine the delta is not working properly. sometimes the infopackage does not get all the records.

What is the right way to pull the data from this table?

should I select a diferent Field? should I change the delta process? or what do you think would be the solution?

Thanks and Regards.

bdatu.png (4.1 kB)
delta conf.png (11.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Apr 05, 2016 at 01:47 AM

    Hi,

    Stocks(available\pickup) of each storage type in LQUA keep on changing , you can not use last movement data as a delta filed to fetch data to BW.

    Instead , have a look at below points.

    1. create a virtual provider based on DTP (direct access)
    2. transformations
    3. create direct data access dtp, as generic data source's are enabled with direct access by default (data source-->change mode-->extraction tab-->choose direct access as "allowed").
    4. no need to run infopackage/dtp.
    5. then create reports.
    6. you can always match BW data against ECC , all you need to do is refresh the report when there is a change in ECC 😊.
    Add comment
    10|10000 characters needed characters exceeded