Skip to Content
avatar image
Former Member

BRrecover ASM

Has anyone used brrecover utility for system copy from one server another server. Our SAP installation is on Oracle 12c using ASM with Grid on Linux OS. The backup is configured with brtools using RMAN and the full backup executed successfully without any errors. I followed note 1003028 to prepare the restore on the target system and initiated the command 'brrecover -t reset -b last -f <NEW_SID> -u /'. As the intial step, brrecover identified the control file correctly and restored from the tape into its temporary location '/oracle/<SID>/sapbackup/cntrl<OLD_SID>.dbf. However, it failed with an error when it tried to copy the control file from its temporary location to its permanent location in the ASM. It looks like copy command in asm cannot use the incarnation #s and they should be omitted. However, the copy command is executed by brrecover tool and I am not sure how do I interrupt to make the control file copy execute with correct syntax.

BR0280I BRRESTORE time stamp: 2016-03-31 17:24:37

BR0407I Restore of database: BX1

BR0408I BRRESTORE action ID: resvthbh

BR0409I BRRESTORE function ID: rsb

BR0449I Restore mode: partial

BR0411I Database files for restore:

+DATA/BX1/CONTROLFILE/current.261.907163733=+DATA/BX1/CONTROLFILE/current.261.907163733

+REDO/BX1/CONTROLFILE/current.256.907163733=+REDO/BX1/CONTROLFILE/current.256.907163733

BR0419I Files will be restored from backup: besvtffa.anr 2016-03-31

17:03:42

BR0416I 1 file found to restore, size 15.766 MB

BR0424I Files will not be decompressed

BR0421I Restore device type: rman_util

BR0351I Restoring +DATA/BX1/CONTROLFILE/current.261.907163733

BR0355I from /oracle/BX1/sapbackup/cntrlBX1.dbf ...

BR0278E Command output of 'ORACLE_SID=+ASM

ORACLE_HOME=/opt/oracle/product/grid/12102_1601

/oracle/BX1/121/bin/asmcmd --privilege sysdba cp

/oracle/BX1/sapbackup/cntrlBX1.dbf

+DATA/BX1/CONTROLFILE/current.261.907163733':

copying /oracle/BX1/sapbackup/cntrlBX1.dbf ->

+DATA/BX1/CONTROLFILE/current.261.907163733

ASMCMD-8016: copy source '/oracle/BX1/sapbackup/cntrlBX1.dbf' and

target

'+DATA/BX1/CONTROLFILE/current.261.907163733' failed

ORA-15056: additional error message

ORA-15046: ASM file name '+DATA/BX1/CONTROLFILE/current.261.907163733'

is not in single-file creation form

ORA-06512: at "SYS.X$DBMS_DISKGROUP", line 486

ORA-06512: at line 3 (DBD ERROR: OCIStmtExecute)

BR0280I BRRESTORE time stamp: 2016-03-31 17:18:11



Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Apr 07, 2016 at 07:40 PM

    Try to use RMAN duplicate from active database it is worth to try (or from backup maybe, never tried that).

    Regarding your case, maybe you can just restore the file to FS and after put it to the ASM DG by manual command?

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Sergo,

      Thanks for your response. I will definitely look into RMAN duplicate from backup. As for my current problem, I tried restoring manually the control file and copied into ASM DG. However, when I had to execute brrecover command to restore the datafiles, it goes back to the beginning and does not think that the control file already restored and continue with the datafile recovery. brrecover is a complete utility and it cannot be interrupted in the middle. After multiple trials, I was able to successfully restore the whole database using brrecover without any errors in between. I had to create an asm alias on the source database, before it was backed up and it resolved the issue of pulling the control file and automatically copying to the correct location in ASM.

  • Apr 09, 2016 at 06:31 AM

    Balu , that's fine, in notes and docs about ASM with SAP it is mentioned , about aliases

    for some files on database.

    Add comment
    10|10000 characters needed characters exceeded