Skip to Content

Wrong Password in ASE Cockpit

Hi,

after installing ASE 16.0 SP02 PL03 over the existing 16.0 SP02 PL02 it is not possible to enter ASE Cockpit. The Cockpit Server starts fine on his https://dimotion:4283/cockpit/ webpage the ASE name (DIMOTION) appears and I enter "sa" and the not changed password. The answer is allways "Login failed.".

I droped the $SYBASE/COCKPIT-4/plugins/DIMOTION directory and copy the existing $SYBASE/COCKPIT-4/templates/com.sybase.ase into a new

$SYBASE/COCKPIT-4/plugins/DIMOTION directory. Using the same existing agent-plugin.xml file I used for the 16.0 SP02 PL02 installation I generate a new agent. But after entering the "sa" password I also got "Login failed.".

I modified the existing agent-plugin.xml file three times to set a new encrypted password into the <set-property property="ase.password" value="<passwd>" /> line but the answer is allways the same "Login failed."...

Attached is the used agent-plugin.xml I used for creating a new agent.

Many thanks


Robert

agent-plugin.xml (2.6 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    Mar 31, 2016 at 03:56 PM

    Hi Robert,

    There's a few things to setup to successfully connect.


    Firstly, the password in the agent-plugin.xml is used by cockpit to connect to ASE. This isn't compared against the password used to login from https://dimotion:4283/cockpit/

    When connecting from the https address, the login and password are sent to ASE. I see your agent-plugin.xml file doesn't have the entire picture of where your ASE resides.

    Having said that, let's look at a few things to get you back to connecting:

    1. shutdown cockpit server

    2. Modify your agent-plugin.xml file for the following settings, uncomment where necessary:

    <set-property property="ase.server.name" value=""/>

    <set-property property="com.sybase.home" value=""/>

    <set-property property="ase.home" value=""/>

    <set-property property="ase.server.log" value=""/>

    <set-property property="ase.start.command" value=""/>

    <set-property property="ase.user" value="sa"/>

    <set-property property="ase.password" value=""/>

    Where value="" is modified to be:

    "ase.server.name" value="" should be the name of your ASE

    "com.sybase.home" value="" is the full /path/to/$SYBASE

    "ase.home" value="" is the /path/to/$SYBASE/$SYBASE_ASE

    for added convenience to cockpit:

    "ase.start.command" value="" is the /path/to/your/RUN_server file

    "ase.server.log" value="" is the /path/to/your/ASEs/errorlog

    Finally ase.user is an sa login, ase.password is the password as supplied by passencrypt.

    The reason why it is important to make these modifications when cockpit is shutdown, is because modifications made while it is running are lost upon shutdown since cockpit flushes in memory settings to the agent-plugin.xml file.

    3. After modifications are made, start your cockpit server (I use a script to run it in the background)

    $ cat start_cockpit

    nohup cockpit.sh 2>&1 > cockpit.out &

    4. Login to cockpit from https address. If all works ok (and you have an interfaces file in "com.sybase.home") you are all set.

    Considerations beyond this.

    You might have to set a technical user and register an agent. Also, another reboot of cockpit at this time will auto-populate the rest of the necessary settings into agent-plugin.xml. This isn't required as it will naturally happen the next time it is booted, and the settings are in memory.

    HTH

    Dan

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Daniel,

      thanks for the details about the agent-plugin.xml file. I tried other login/user and it also didn't work.

      I renamed my COCKPIT-4 directory to COCKPIT-4_back and reexecute setup.bin. This generates a new COCKPIT-4 directory. Using the same(!) agent-plugin.xml as before and not it's no problem to login as sa and other users.

      Robert

  • avatar image
    Former Member
    Apr 07, 2016 at 06:53 PM

    Yes, the same problem on Windows ((((

    Add comment
    10|10000 characters needed characters exceeded