Skip to Content

Work processes going in ENQ and system is getting slow

Hey Experts,

Hope everyone is doing great,

I have noticed that once in every month whenever i checked my SM66 i see my work processes going in ENQ and my system is getting slow.

I always try to kill the long running ENQ processes but nothing happens system doesn't come in normal state and for this reason i always need to take a downtime and restart the system again.

We are having ESS MSS running in our system with 3 R3 Application server and 5 Java application server.

I have checked the lock entries there are only 38 lock entries this time when i checked.

Can anyone please help me analysing this issue.

I want to know why this happens once in every month ? and what can be done to avoid this situation ? and if this situation arises what can be done to make system normal instead of restarting the SAP.

Please help me.

Thanks and regards,


SM66.JPG (173.5 kB)
Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

5 Answers

  • Best Answer
    Mar 31, 2016 at 08:23 AM

    Hi Musa,


    workprocess Running ENQ SAPLSENA

    which means that the workprocess has sent enqueue request to ENQ server, but there is no response from ENQ server yet.

    I suppose that you are using ASCS standalone enqueue server.

    the possible causes are:

    1, ENQ server problem

    => if so, you should find some errors from dev_enq* trace file

    2, network issues which block communication between DI and ENQ server

    => you can ask you network admin to troubleshooting it when issue is happening again

    3, are you enable ERS server ? it could be synchronize problem between ENQ server and ERS server

    => you can just try to disable ERS server and check again

    Since this issue happens once in every month, does this issue occur on the same period every time ?

    what did you perform during that period every month ?

    Probably the special actions which performed every month cause this issue(see possible reasons above).

    Thanks and best regards,


    Add comment
    10|10000 characters needed characters exceeded

  • Mar 31, 2016 at 09:03 AM


    Double click on the ERROR column & see what error you are getting ?

    Also, check dev_enque* trace file for any issues.



    Add comment
    10|10000 characters needed characters exceeded

    • Hello,

      SM12 -> β€œtest” in OK/command window then you will see extra option in menu bar Error handling -> Diagnosis Environment.

      Be VERY CAREFUL with that πŸ˜‰. Some menu options under "Error handling" can break the system.

      Another possibility for the work processes to be waiting for the enqueue is that an application is overloading the enqueue with requests. You have mentioned that you see this once per month. Is it during the same period of the month? Let's say, during moth end closing? 😊

      What specific jobs are executed then?

      About the note 1384191, check out this WIKI page as well.



  • Mar 31, 2016 at 07:20 AM

    Hello Rbk,

    Can you check the note 1384191 - SM50: Many processes in status "holds ENQ"

    And the link


    Yuksel AKCINAR

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 02, 2016 at 06:41 PM

    if it's on BALHANDLE

    can you try if these notes gets applied to your system

    I had same issue in Solman and the above notes resolved them.

    Add comment
    10|10000 characters needed characters exceeded

  • Apr 05, 2016 at 07:23 AM

    Sorry Guys for the very late reply. Actually i was very busy in Year End activities.

    Thanks everyone for their valuable reply in my absence.

    I have followed couple of SAP notes but according to that notes i couldn't be able to resolve my issue.

    I followed this above note

    Solution -

    • Call transaction SM12. In the command field (also called OK code field), enter "test" (without the "") and press the Enter key.
    • After you do this, the system displays another pull-down menu called "Error handling".
    • From the pull-down menu, choose "Error handling - Logging - Switch On" and wait for approximately ten seconds.
    • Then choose "Error handling - Logging - Switch Off" from the pull-down menu.
    • Finally, choose "Error handling - Logging - Display" from the pull-down menu.
    • Save the list that is displayed in a local file. When you do this, choose "unconverted" for the format in which the list should be saved. You can compress the file and attach it to a message.

    I followed these above given steps but the logs are coming empty after performing these steps in SM12



    Add comment
    10|10000 characters needed characters exceeded