Skip to Content
avatar image
Former Member

Error when mapping fields of external list

Hi experts,

When I try to map the fields of the external list, the information is not mapped correctly.

This is the steps I followed:

1. I defined a origin list and list type

2. I implemented the workflow customizing WS14000029 (and assign to general task) and with tx. SWU3 I mantained all the settings.

3. I create a Mapping Format

4. Assign the necessary fields to my format

5. Create ELM

6. My mapping format it's only for activities. And I only "tick" Read File and Map Data.

When execute the external list, the information is not mapping correctly.

Can anyone help me?

Kind regards,

David

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Mar 31, 2016 at 07:31 AM

    Hello,

    can you provide some further information - what exactly is not mapped correctly. Can you provide some screenshots of the mapping format and a sample line of the CSV file to be uploaded.

    regards,

    Johannes

    Add comment
    10|10000 characters needed characters exceeded

    • Hello,

      when looking at the mapping rule the following points may cause the issue:

      1. OBJECT_ID: this has mapping rule 'code' assigned - is this required? What I understand is that the OBJECT_ID is required just in case you want to update existing activities, for generating new activities this is not required at all. What kind of code is used for the OBJECT_ID?
      2. PROCESS_TYPE: this has mapping rule 'values' assigned - make sure that the transaction type 'ZA01' is mapped in the values table.
      3. ACTUAL_DATE_TO: make sure that the value '30/03/2016' is in the correct date format assigned to user WF_BATCH
      4. STATUS: this has mapping rule 'constant' assigned. Indepenently of the value 'E0011' any constant is used for the upload. What is the value in the constant? Further when using the user status I would suggest to provide the user status profile together with the user status value.

      I would do the following:

      1. remove all the mapping rules and test again
      2. in case you want to generate new activities also remove the OBJECT_ID from the mapping but provide any DESCRIPTION instead

      In case this won't help you can try to debug the mapping - the following wiki page contains the detailed steps:

      How to debug an External List - CRM - SCN Wiki

      The function module CRM_MKTLIST_STAGING_CONVERT is doing the 'map data' step.

      You may also refer to the following document:

      External List Management Handbook

      regards,

      Johannes