Skip to Content

Missing realtime records in Hana

Hi All,

I see a small latency in item details i.e vbap information when replicated through SLT . When i do realtime reporting using this transactional information it's incorrect. For example for Sales Order there are some line items missing in Hana i.e didn't get replicated yet at the time of reporting or view execution , however header and some items did get replicated. How can we handle this situation? Please help , this is urgent. Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

1 Answer

  • Best Answer
    Mar 30, 2016 at 06:25 AM

    This is a standard effect of independently replicated tables, instead of transaction-based replication.

    In a way you can call this "eventual consistency" as the data will be correct and consistent after some time.

    I'm not too sure about SLT's abilities to guarantee transaction consistency on the replication side - you might ask a question over at SAP LT Replication Server

    As for "urgent" - this is the wrong place for "urgent", "critical" or "immediate". This is a internet user forum based on volunteer's effort to help each other. If you need "urgent" you might want to go for a commercial service to help you.

    Add comment
    10|10000 characters needed characters exceeded

    • Nope, there's nothing to "monitor" here, since neither SLT nor SAP HANA know about which tables belong together on the source side.

      You may consider to include filter conditions into your queries that only show data from, e.g. around 5 mins ago, to ensure that all dependent records have meanwhile been replicated.

      If and how this is possible depends on the tables you're dealing with and if they come with some sort of update timestamp.