Skip to Content
avatar image
Former Member

Assertion failed: Unable to setup database device

Hi Gurus,

I am trying to install SAP ERP 6.0 EHP 8 on SUSE 12 and Sybase 16.0..02.02

This SUSE 12 instance is setup on VMWare

While installing, the setup is giving me error while configuring the database. The error is "Assertion failed: Unable to setup database device"

I have referred few SAP Notes for this but could not find any precise solution. In one of the SAP Notes, I found out the reason being that Sybase is using more than 4100 MB of RAM. I tried the installation by allocating 15 GB of RAM but the error is same

Can anyone advice on this situation or any exact SAP Note which gives solution on this

R..../-

Add comment
10|10000 characters needed characters exceeded

  • Follow
  • Get RSS Feed

2 Answers

  • Best Answer
    Apr 05, 2016 at 07:34 PM

    Hi Sandy,

    I has the similar problrem i aplly the two workarond.

    1) I reduce memory for WPAR to 10MB and the install is working

    2) After i used the old version of SWPM and it's word too.

    The problem for us ERP 6.0 System Copy in AIX System

    We migrate from ORacle to Sybase 16.0 and we received the same error, the install continue after two workaround.

    I think this is a Bug of the ASE and the SWPM.

    If you need I send the SWPM version.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Issue resolved due to shortage of space in /sybase/SID

      Error was occurring before consuming the available space in this filesystem thus was confusing

      Thanks Mario Luis Faria dos Santos

  • avatar image
    Former Member
    Mar 29, 2016 at 02:40 PM

    So far I have tried these things:


    — SAP Notes


    SAP Note 1940536, SAP Note 1581695, SAP Note 1539124, SAP Note 1837579, SAP Note 1889468. All these SAP Notes either point to each other without giving any solution of ask to set some parameter from DBACOCKPIT which I cannot as I am getting the said error while installation and thus my ASE or SAP is not yet ready


    — Ulimit to resources


    ulimit -m unlimited

    ulimit -v unlimited

    Add comment
    10|10000 characters needed characters exceeded