Skip to Content

analysis office 2.2 bip addon install failed

hi,

on the server windows 2012 r2 both version of .net 3.5 and 4.5 were installed. the setup checks the prerequisites and sets the status for prerequisite 'microsoft .net framework 4.5 or higher' on failed.

after the uninstall of .net 3.5 and restart the server, the same failure: please install 'microsoft .net framework 4.5 or higher'.

an idea how to deal with that here?

thanks,

zaki

Add a comment
10|10000 characters needed characters exceeded

Related questions

5 Answers

  • Posted on Apr 19, 2016 at 09:18 AM

    I had the same issue on a Windows 2012 R2 and a Windows 2014 Server. As Note 2302655 is not helpful at all (because SP3 not yet released), I searched for the root cause of this issue.

    The problem is that .NET 4.5 installation on the server is too new. If you check registry HKLM>Software>Microsoft>NET Framework Setup>NDP>v4>Full in Key "Version" you will see that version string is 4.6 and not 4.5 (in my case it was 4.6.01055, which is 4.6.1, which is KB3102467).

    Solutions is to uninstall .NET 4.6.1 (if not required by other software installed on the servers). This version came as "Update for Microsoft Windows (KB3102467)", so uninstall this KB using "Programs and Features" > "Installed updates", restart Windows and start AO-Installation again.

    (Ugly way which could possibly work: try to modify registry, start installation, switch back)

    Hope that helps.

    BR,

    Markus

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 22, 2016 at 05:00 PM

    Maybe try installing a higher version of 4.5 .NET framework? If you still experience issues, I would open a SAP Support incident

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 18, 2016 at 10:57 AM

    Try again the installation, and right after open the installation log ("C:\Program Files\SAP\SapSetup\LOGs\NwSapSetup.log" if 32 bit Windows or "C:\Program Files (x86)\SAP\SapSetup\LOGs\NwSapSetup.log" if 64 bit Windows) and look for an error on detecting the .NET Framework (it might be a left-over key from an older version).

    I recently found out the installer does a thorough verification of all installed software and a more detailed on a few ones like (.NET Framework, Office, VSTO, Adobe Reader, JDK and JRE).

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 19, 2016 at 07:42 AM

    Hi,

    I'm dealing with the same issue when try installing SP03 in my environment. Same issue on 3 Servers.

    The setup checks the prerequisites and sets the status for prerequisite 'microsoft .net framework 4.5 or higher' on failed.


    All of my Systems (Sandbox, Development and Productive) the same behaviour.


    Any ideas?


    br Sascha

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Apr 28, 2016 at 07:35 AM

    Hi All,

    Me too facing issues with AA 2.2

    Initially the below error was coming up while installation ::

    Later on, once the required software's were installed and AA 2.2 also got installed facing the below error while trying to insert data source ::

    Did someone face the same issue or someone can help on this?

    Regards,

    Abhijit


    AA 2.2 Error.JPG (126.7 kB)
    Error.JPG (28.6 kB)
    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.