Skip to Content

FPM in standards mode in EP

Hello,

We are experiencing problems when trying to start a FPM application in standards mode in the enterprise portal. (7.40 SP11)

Error:

The FPM we are trying to start contains HTML islands. Currently when we try to start the view with the HTML islands we are getting shortdump: 'To use a UI element of type HTML_ISLAND, the application must be executed in the "Standards" browser mode'. However our portal runs in standards mode and at the moment we don't see why this application isn't handled as such.

Flow:

- FPM application is started in our portal. When starting the portal, the HTTP response header x-ua-compatible with value IE=edge is visible in Fiddler. IE Developer tools indicates 'Standards' mode is the default rendering mode.

- When clicking on a specific button inside this FPM, another FPM is opened in a new browser window. This application is also embedded in the portal and is started via a Quick Link.

- The new window is started and again the HTTP header x-ua-compatible: IE=edge is visible in Fiddler. However when navigating to the view with the HTML island, the short dump occurs.

After consulting lots of documentation, we changed the configuration on diverse levels but for now without success:

- FPM application parameter WDPREFERREDRENDERING to "standards"

- iView config:

- Hand over Browser Document Mode Parameter: checked

- added application parameter: sap-ie=EDGE

- Default Document Rendering Mode: Standards

- Launch in new Window: Display in separate headerless portal window (standards mode) (although I don't think this will affect the behaviour since it's started via a Quick Link?)

I guess we overlook something... Please let me know if something is not clear!

Any help is greatly appreciated!

Kind regards,

Maarten

Add a comment
10|10000 characters needed characters exceeded

Related questions

1 Answer

  • Best Answer
    Posted on Mar 14, 2016 at 11:45 AM

    Hi Marteen,

    Many thanks for using SCN Discussions Forum 😊

    I have done a quick search regarding this issue and have you configured the application itself to standard browser mode?


    From what I understand you are using the Portal and it is rendering in IE=Edge according to the Browser Document Mode of the current Framework Page you are using?


    I have checked this FPM application you mentioned and a note shows up for configuring the FPM application for Standards Mode 1987004 - Adjust FPM config to standard browser mode.

    Best Regards,
    Jinnyre Malazarte - Enterprise Portal Support Engineer

    Follow Jinnyre Malazarte

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.