Skip to Content
avatar image
Former Member

Purging doesn't work always

Hi,

I am having a strange behavior where purging do not work correctly every time.

(1) PUT = http://<Servername>:6405/biprws/raylight/v1/documents/33280/dataproviders/DP0?purge=true

The above URL doesn't work, so i tried like below and it worked.

(2) PUT = http://<Servername>:6405/biprws/raylight/v1/documents/33280?purge=true

When i tried the same above URL (2) for another report it did not work. To make it work i have to first execute URL (1) and then URL (2).

Not clear what i should do? Do i have to execute both the URLs?

Appreciate your help.

Thanks,

Arun

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Mar 14, 2016 at 07:57 AM

    hello Arun

    1. Can you please detail your "The above URL doesn't work" for "PUT .../dataproviders/{dpId}?purge=true" ?

    2. "?purge" is not implemented for "PUT .../documents/{docId}", hence the result is exactly the same as if you didn't provide the extra URL parameter "?purge=true".

    3. What version are you running? ("GET ../raylight/v1/about")

    Regards,

    eric

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Daniel Paulsen

      Thanks Dan.

      Don't have much experience in RESTFUL, but going by what i have done restful seems much more complicated than JAVA SDK. There is no straight forward solution that can be implemented for business users. SAP should have some thing like the earlier document.purge() instead of going through DP0, DP1, <state> etc. Being complicated is the exact reason why Xcelsius dashboard is getting replaced by Tableau and Qlikview, soon some one will come up with an alternative for BO as well.