Skip to Content

IUUC_REPL_CONTENT, Table Settings, Partition Command changes drops table

I came across a SAP LT issue recently that I would like to share since it currently has a bad side effect. I am working with SAP Support to get it fixed.

We have HANA table partitioning configured in SAP LT instead of HANA directly. This was done to save time when replicating SAP ECC 6.0 data to HANA since getting the table loaded and partitioned occurs in one step.  This is especially helpful when performing SAP test system refreshes which we do 2 - 4 times a year and partitioning large tables out of our 3.5 TB source database.

The issue we are encountering is occurring with DMIS 2011_1_731 SP 8 or SP 10 installed in a dedicated SAP LT server. When running transaction IUUC_REPL_CONTENT and using the Table Settings, Partition Command, two things are not working right: 

  1. When saving Partition Command modifications, the system drops spaces from the defintion.  This results in errors when saving or worse, it saves but then the table doesn't replicate properly due to syntax issues.
  2. Making changes to the defintion in the Partition Command section on a table that is currently replicating results in that table being dropped from HANA!  This has occurred to us with a SAP LT DMIS SP 10 system replicating to HANA revision 102 and a SAP LT DMIS SP 8 system replicating to HANA revision 96.  In each system, the table was dropped after saving the changes in IUUC_REPL_CONTENT but the LTRC display of replicating tables did not reflect that the destination table no longer existed in HANA.

Lesson learned until a fix is created:  don't change your partitioning configuration in SAP LT unless you plan to also drop and replicate your data from scratch.

Robert

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Mar 08, 2016 at 09:41 PM

    Great article! I will take this into consideration!

    Add comment
    10|10000 characters needed characters exceeded