Skip to Content
author's profile photo Former Member
Former Member

When shall we use “execute in SQL Engine”?

Observation: In one graphic calculation view, a script-based calculation view is used. If “execute in SQL engine” is not selected, the calculation results

  1. Are correct in HANA data preview
  2. Are correct in Lumira
  3. Are wrong in Analysis for Office
  4. Are wrong in Design Studio

Question: what is the best practice regarding “execute in SQL engine”? In which situation must this option be selected? In which situation must this option be kept empty?

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Posted on Mar 01, 2016 at 10:01 AM

    If the results differ with the SQL engine option selected, that most likely has to do with the semantic differences in how e.g. NULL are handled by the CE- respectively the SQL functions.

    Please check http://service.sap.com/sap/support/notes/1857202 and in case this doesn't cut it http://service.sap.com/sap/support/notes/2222121.

    Add a comment
    10|10000 characters needed characters exceeded

    • Nope, I don't have specifics of the mentioned clients.

      As a SAP employee you may want to open internal support messages in case of wrong result sets.

      Given your information, the SQL Engine flag and the wrong results coincide in 50% of the cases. That seems to be similar to rather chance and not correlation.

  • Posted on Mar 01, 2016 at 09:59 AM

    The document attached to note 1857202 - SQL execution in Calculation Views should answer most of your questions.

    Regards,

    Florian

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Lars Breddemann

      Hi,

      I read the notes but still don’t understand when to use SQL engine.

      In our case we have a CV that for some queries the SQL engine flag make better performance but for other SQL queries we get OOM (which we don’t get without this flag).

      I there any rule of thumb?

      We are in SP11.

      Thanks,

      Amir

  • Posted on Mar 07, 2016 at 08:59 PM

    Hi all,

    I am also facing some issues and differences between HANA studio and Design Studio. When I am executing the view in HANA studio I am getting results for calculated columns, in Design Studio only 0 is shown. Can this be related to the same issue?

    I tried to have different settings with the SQL engine flag, but for me it didn't help.

    I will follow up with Ye on an internal ticket as well, but I hoped somebody faced the same issue and found a solution for that.

    Thanks a lot,

    Juliane

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.