Skip to Content
avatar image
Former Member

Problem starting server

I have successfully installed NetWeaver Preview edition SP15 and tested it by starting and connecting to the WWW server. Later, when I restarted the machine, I found that some Windows services were automatically configured to start. Since I was not planning to use NetWeaver all the time and since the services were slowing down my machine I

stopped the services and configured all of them to be started manually.

Now, if I restart the machine and if I start the server from mgmt console, it is not starting. The developer trace on jcontorl.exe process shows:

[Thr 1628] *** ERROR => invalid return code of process [bootstrap] (exitcode=66) [jstartxx.c 1452]

[Thr 1628] JControlExecuteBootstrap: error executing bootstrap node [bootstrap] (rc=66)

[Thr 1628] JControlCloseProgram: started (exitcode = 66)

[Thr 1628] JControlCloseProgram: good bye... (exitcode=66)

The Database is in online mode. I started a few services manually to check if that solved the problem. Some services started and some did not. The list of NetWeaver services and their status are as follows:

SAP DB WWW Started

SAPDB: .M750018 Stopped

SAPDB: .M750018 (omststknl.exe) Stopped

SAPDB: .M750018 (quick) Stopped

SAPDB: .M750018 (slow) Stopped

SAPDB: J2E Started

SAPDB: J2E (omststknl.exe) Stopped

SAPDB: J2E (quick) Stopped

SAPDB: J2E (slow) Stopped

SAPDBXIE Started

SAPJ2E_00 Started

SAPJ2E_01 Started

SAPOsCol Started

The output of sapdb\data\wrk\.M750018\knldiag is as follows:

============================================ begin of write cycle ==================

2006-02-22 12:22:17 0x2F4 208 RTE Database tries automatic restart

2006-02-22 12:22:17 0xD3C 19821 TASKING Thread 3388 starting

2006-02-22 12:22:17 0xBEC 19633 CONNECT Connect req. (T4, Node:'', PID:3392)

2006-02-22 12:22:17 0xBEC 19615 VOLUMEIO Attaching volume 'CHECKDEV'

2006-02-22 12:22:17 0x440 ERR 18159 VOLUMEIO Could not open volume 'CHECKDEV', rc = 2

2006-02-22 12:22:17 0xBEC ERR 14 IOMan Attach error on Data volume 1: could not open volume

2006-02-22 12:22:17 0xBEC ERR 15 Admin RestartFilesystem failed with 'I/O error'

2006-02-22 12:22:17 0xBEC ERR 8 Admin ERROR 'disk_not_accessibl' CAUSED EMERGENCY SHUTDOWN

2006-02-22 12:22:17 0xBEC 19620 DBSTATE Shutdown normal requested

2006-02-22 12:22:17 0xBE4 19617 VOLUMEIO Single I/O attach, 'knltrace', UKT:1

2006-02-22 12:22:17 0x788 19684 TASKING Tracewriter termination timeout: 1200 sec

2006-02-22 12:22:17 0xBE4 19619 TASKING Releasing tracewriter

2006-02-22 12:22:17 0x788 19890 DIAGHIST Backup of diagnostic files will be forced at next restart

2006-02-22 12:22:17 0x788 19600 VERSION 'Kernel 7.5.0 Build 018-123-079-776'

2006-02-22 12:22:17 0x788 19654 DBSTATE SERVERDB '.M750018' has stopped

-


current write position -


I am logging in to Windows as the same Admin user who installed NetWeaver.

Could you please let me know how I can start the server?

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Feb 22, 2006 at 11:56 PM

    Hi Daisy,

    Please look at the system.log file in bootstrap folder. It'll give you the reason for the problem. Looking at the exit code, it seems the database is not running. Please check it once again.

    Regards,

    Siva

    P.S: Award points if you find this useful.

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Problem solved. There was a Windows service called 'XServer' that had not been started. Once this was started, the NetWeaver server also started.

      Thanks.