Skip to Content
0

Query problem with VBPA-LAND1 as selected field

Feb 06, 2017 at 02:56 PM

53

avatar image

Hi,

I've created a query with VBRK-VBRP and extract with a select the VBPA-LAND1. The query works properly, but if I use as selected filed the custom field (VBPA-LAND1) the query extract no values.

Could you please help me?

Thanks and regards.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Jürgen L
Feb 06, 2017 at 03:24 PM
0

Why do you call VBPA-LAND1 a "custom field"?

Such questions cannot be answered without seeing some screenshots. A query is an object that you defined yourself, we neither know what you did nor do we know what you have in your data base.

So at least a screenshot of your filled selection screen would be needed, as well as a screenshot from SE16 table view showing entries that should have been found.

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Hi,

As wrote I extract the VBPA-LAND1 with select:

select single KUNNR ADRNR LAND1 from VBPA into (WE, IND, PWE)

where VBELN = VBAK-VBELN

and PARVW = 'WE'.

Ad described the query works properly, only when i use the PWE as selected field the query extracts no values.

The only thing is that the country appear with 2 digit but the field is based on 3 digit.

Regards.

0

sorry, but I do not understand this reply.

0

Don't worry I've solved.

Thanks a regards.

0

Then you should share how it was solved so that future readers can learn something if they have same question

0
Antonio Bruno Feb 20, 2017 at 03:10 PM
0

I've used directly the standard field VBRK-LAND1 to extract the Destination Country.

Share
10 |10000 characters needed characters left characters exceeded