Skip to Content
author's profile photo Former Member
Former Member

Design Studio 1.6 ignores Filter Member and changing Prompts

Hi All,

It seems my Design Studio lives its own life. 😊

So, I have DS 16.0.5, Analysis for Office 2.2 SP1, SAP BW 7.31 SP16, BI Platform 4.2 SP1

BEx has a simple BW Query, Controlling Area (CA), Cost Center (CC), Cost Element (CE), Year (Y), Month (M) and Amount (A). CA, CC and Y are variables, CA and Y single-value and mandatory, CC selection option and optional.

First I have built Workbook with 3 tabs in Analysis based on that BEx Query, CA and Y are the same for all 3 tabs, CC not: 1001, 1002, 1003, 1004 for the first and second, 1003, 1004, 1005, 1006 for the third. No issues, everything looks fine. Then I have clicked the Create Web Application button, log on to my BI Platform and all three tabs are exported to DS.

Now the strange

1.1. All my tables in all three tabs have CC 1001, 1002, 1003, 1004 already in DS.

1.2. Click Edit Initial View for the Data Source 3. CC is 1001, 1002, 1003, 1004. I change it manually with Filter by InputString for 1003, 1004, 1005, 1006, preview shows everything correct. OK + create new crosstab. Nothing changes, it is still wrong.

1.3. Go to Show Prompts. CA and Y are OK, and CC is 1001, 1002, 1003, 1004. Reset them, click OK. Now I see all CC values in all three tabs

1.4. Edit Initial View for the Data Source 1. Change CC manually with Filter by InputString for 1001, 1002, 1003, 1004, preview shows everything correct. But neither OK nor OK + create new crosstab gives me the correct result, I still see all members.

2.1. I decide to change DS prompt CC for 1003, 1004, 1005, 1006. Of course, all my three tabs are showing 1003, 1004, 1005, 1006 now as well as Data Sources.

2.2. Save, click Execute locally, Browser IE11 is opened, I go to tab three and... I see that CC is 1001, 1002, 1003, 1004!!!

2.3. Check DS, close it, close browser, open and click Execute locally. Again, CC is 1001, 1002, 1003, 1004 in Browser but 1003, 1004, 1005, 1006 in DS

2.4. Copy link and open it FF browser. Again, CC is 1001, 1002, 1003, 1004.

3.1. I go to Analysis once again, check Workbook, click Create Web Application and receive again the same as in Step 1.1

What is happening?! 😕

Thanks and Regards,

Ekaterina

Add a comment
10|10000 characters needed characters exceeded

Related questions

2 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Feb 15, 2016 at 09:49 PM

    Hi Ekaterina,

    can you try unmerging the prompts on the application level.

    thanks

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Naveen,

      This is what I do, but it seems to be workaround, setting a fake prompt value in "On variable initialization" and re-defining in "On before prompts submit" with a script.

      I already have 2 of 3 Data sources, where prompts are saved, and try to find out why I don't receive the same for the third.

      Regards,

      Ekaterina

  • author's profile photo Former Member
    Former Member
    Posted on Feb 12, 2016 at 03:30 PM

    Hi Ekaterina,

    Are you using .SetVariableValue function to amend the prompts values? (during Runtime)

    If so, please read:

    Regards,

    Bogdan

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.